使用 Maya 與 Substance Painter 建立 GLB 檔案

您可以使用 Maya 與 Substance Painter 匯出 GLB 檔案,之後可在 Shopify 管理介面中將其新增至商品。3D 模型可協助顧客視覺化商品,提升購買信心並降低退貨率。

在 Maya 中準備模型以供匯出

為了準備匯出,請確保模型為單一網格,且只套用一個材質。

步驟:

  1. 在 Maya 中,依序按一下 File > Import...,選取您的 3D 檔案,然後按一下 Import
  2. 按一下 Mesh > Combine,將網格合併為單一物件。
  3. 將模型的 UV 展開至 0–1 空間。請確保沒有 UV 重疊:
    使用 UV 編輯器,將 UV 佈局在 X 與 Y 軸的 0 到 1 區間。
  4. 將 Phong 材質套用至模型:
    1. 將滑鼠游標移到模型上,按住滑鼠右鍵,然後選取 Assign New Material...
    2. 在對話方塊中選取 Phong

從 Maya 匯出網格

  1. 選取整個網格,然後按一下 File > Export Selection...
  2. 輸入檔名與儲存位置。
  3. Files of type 下拉式選單中,選取 OBJexport
  4. 按一下 Export Selection

在 Substance Painter 匯入並準備 OBJ 檔案

  1. 按一下 File > New,建立新的 Substance Painter 專案。
  2. New project 對話方塊中,按一下 Select 選取網格。
  3. 選取您從 Maya 匯出的 OBJ 檔案,然後按一下 Open
  4. New project 視窗中,按一下 OK
  5. 請透過檢查 Texture set list 面板中是否只有一個貼圖集,來確認您已正確匯出網格。
  6. Texture set settings 面板中,按一下 + 按鈕以新增通道:
    「+」按鈕位於 Channels 標題旁。按一下該按鈕會開啟下拉式選單,顯示可用的其他通道。
    • 必要:Ambient occlusion。
    • 選用:Emissive。若模型中有會發光的部件,請新增此通道。
    • 選用:Opacity。若模型中有需要透明的部件,請新增此通道。
  7. Texture set settings 面板中,按一下 Bake Mesh Maps
  8. 在模型上繪製貼圖。

多個貼圖集

將 OBJ 檔案匯入 Substance Painter 時,應只有一個貼圖集:

材質集會列在材質集清單面板中。

如果顯示多於一個材質集,代表從 Maya 匯出網格時,下列其中一項有誤:

  • 未將網格合併為單一物件。
  • 該網格被指派了超過一個材質。

若是如此,請從 Maya 重新匯出模型,並確認網格為單一物件且僅指派一個材質。

從 Substance Painter 匯出 glTF 檔案

  1. 按一下 File > Export Textures

  2. Config 下拉式選單中,選取 glTF PBR Metal Roughness

  3. 選擇要儲存貼圖的位置。

  4. 選擇文件尺寸,以決定貼圖檔案的大小。

  5. 按一下 Export

壓縮貼圖檔案

匯出模型後,您應會得到下列檔案:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

使用 glTF PBR Metal Roughness 設定時,Substance Painter 只會匯出 PNG 格式的貼圖檔案。建議壓縮貼圖檔,並將不需要 Alpha 通道的貼圖轉換成 JPG。這樣可降低總檔案大小;檔案越小,下載速度越快,互動也更順暢。

檔案大小以 4 MB 以內為佳。

建立 GLB 檔案

  1. 前往 https://glb-packer-old.glitch.me/
  2. 將您從 Substance Painter 匯出的檔案拖放到 GLB Packer 網頁。

系統會將名為 out.glb 的檔案下載到您的電腦。下載完成後,您可以重新命名該檔案,然後將其上傳到 Shopify。