Tạo tệp GLB bằng Maya và Substance Painter

Bạn có thể sử dụng Maya và Substance Painter để xuất tệp GLB có thể thêm vào sản phẩm trong bảng điều khiển quản trị Shopify. Mô hình 3D giúp khách hàng hình dung sản phẩm, từ đó tăng độ tin cậy và giảm đơn hàng trả lại.

Chuẩn bị mô hình để xuất trong Maya

Để chuẩn bị xuất mô hình, bạn cần đảm bảo đó là một lưới duy nhất và được áp dụng một vật liệu duy nhất.

Các bước:

  1. Nhập mô hình vào Maya bằng cách chuyển đến File > Import..., chọn tệp 3D, rồi nhấp vào Import.
  2. Nhấp vào Mesh > Combine để kết hợp lưới thành một đối tượng duy nhất.
  3. Mở gói mô hình vào không gian UV 0-1. Đảm bảo không có UV nào chồng lên nhau:
    Sử dụng UV Editor để bố trí các UV từ 0 đến 1 trên trục X và Y.
  4. Áp dụng vật liệu Phong cho mô hình:
    1. Di con trỏ chuột lên mô hình, nhấp và giữ chuột phải, rồi chọn Assign New Material...
    2. Trong hộp thoại, chọn Phong.

Xuất lưới từ Maya

  1. Chọn toàn bộ lưới, rồi nhấp vào File > Export Selection...
  2. Nhập tên tệp và vị trí lưu tệp.
  3. Trong menu thả xuống Files of type, chọn OBJexport.
  4. Nhấp vào Export Selection.

Nhập và chuẩn bị tệp OBJ trong Substance Painter

  1. Tạo dự án Substance Painter mới bằng cách nhấp vào File > New.
  2. Trong hộp thoại New project, nhấp vào Select để chọn lưới.
  3. Chọn tệp OBJ đã xuất từ Maya, rồi nhấp vào Open.
  4. Trong cửa sổ New project, nhấp vào OK.
  5. Xác minh bạn đã xuất lưới chính xác bằng cách kiểm tra xem có duy nhất một bộ kết cấu trong bảng điều khiển Texture set list .
  6. Trong bảng điều khiển Texture set settings , nhấp vào nút + để thêm kênh:
    Nút + nằm bên cạnh tiêu đề Kênh. Nút này mở ra menu thả xuống hiển thị các kênh bổ sung khả dụng.
    • Bắt buộc: Ambient occlusion.
    • Tùy chọn: Emissive. Thêm kênh này nếu mô hình có các thành phần phát sáng.
    • Tùy chọn: Opacity. Thêm kênh này nếu mô hình có các thành phần trong suốt.
  7. Trong bảng điều khiển Texture set settings, nhấp vào Bake Mesh Maps.
  8. Vẽ kết cấu lên mô hình.

Nhiều bộ kết cấu

Khi nhập tệp OBJ vào Substance Painter, chỉ nên có một bộ kết cấu duy nhất:

Các bộ kết cấu được liệt kê trong bảng điều khiển Texture set list.

Nếu hiển thị nhiều hơn một bộ kết cấu thì một trong những lỗi sau đã xảy ra khi xuất lưới từ Maya:

  • Lưới không được kết hợp thành một đối tượng duy nhất.
  • Lưới được gán nhiều hơn một kết cấu.

Nếu gặp trường hợp này, hãy xuất lại mô hình từ Maya và đảm bảo lưới là một đối tượng duy nhất và chỉ được gán một kết cấu duy nhất.

Xuất tệp glTF từ Substance Painter

  1. Nhấp vào File > Export Textures.

  2. Trong menu thả xuống Config, chọn glTF PBR Metal Roughness.

  3. Chọn vị trí lưu kết cấu.

  4. Chọn kích thước tài liệu để xác định độ lớn của tệp kết cấu.

  5. Nhấp vào Export.

Nén tệp kết cấu

Sau khi xuất mô hình, bạn sẽ có các tệp sau:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Khi sử dụng cấu hình glTF PBR Metal Roughness, Substance Painter chỉ xuất tệp kết cấu ở định dạng PNG. Hãy cân nhắc nén tệp kết cấu và chuyển đổi mọi kết cấu không cần kênh alpha thành JPG. Thao tác này giúp giảm tổng kích thước tệp, đồng thời kích thước tệp nhỏ hơn giúp tốc độ tải xuống nhanh hơn và tương tác mượt mà hơn.

Tốt nhất là giữ kích thước tệp ở mức từ 4 MB trở xuống.

Tạo tệp GLB

  1. Truy cập https://glb-packer-old.glitch.me/.
  2. Kéo và thả các tệp đã xuất từ Substance Painter vào trang web GLB Packer.

Tệp có tên out.glb sẽ được tải xuống máy tính. Sau khi tải xuống hoàn tất, bạn có thể đổi tên tệp rồi tải lên Shopify.