Maya اور Substance Painter کا استعمال کرتے ہوئے GLB فائل بنانا
آپ ایسی GLB فائل ایکسپورٹ کرنے کے لیے Maya اور Substance Painter استعمال کر سکتے ہیں جسے Shopify ایڈمن میں کسی پروڈکٹ میں شامل کیا جا سکے۔ 3D ماڈل کسٹمر کو پروڈکٹ کا تصور کرنے میں مدد کر سکتے ہیں، جس سے اعتماد میں اضافہ ہوتا ہے اور ریٹرن میں کمی آ سکتی ہے۔
اس صفحے پر
اپنے ماڈل کو Maya میں ایکسپورٹ کے لیے تیار کریں
اپنے ماڈل کو ایکسپورٹ کے لیے تیار کرنے کی غرض سے، آپ کو یہ یقینی بنانا ہوگا کہ یہ ایک واحد میش ہے اور اس پر ایک واحد میٹریل لگایا گیا ہے۔
اقدامات:
- File > Import... پر جا کر، اپنی 3D فائل کا انتخاب کر کے، اور پھر Import پر کلک کر کے اپنے ماڈل کو Maya میں امپورٹ کریں۔
- اپنے میش کو ایک واحد آبجیکٹ میں ملانے کے لیے Mesh > Combine پر کلک کریں۔
- ماڈل کو 0-1 UV اسپیس میں اَن ریپ کریں۔ یقینی بنائیں کہ کوئی UV اوورلیپ نہ ہو:

- ماڈل پر ایک Phong میٹریل لگائیں:
- ماڈل کے اوپر اپنے ماؤس کرسر کے ساتھ، رائٹ کلک کر کے دبائے رکھیں، اور پھر Assign New Material... کو منتخب کریں۔
- ڈائیلاگ سے، Phong کو منتخب کریں۔
Maya سے میش ایکسپورٹ کریں
- مکمل میش کو منتخب کریں، اور پھر File > Export Selection... پر کلک کریں۔
- ایک فائل نام اور وہ لوکیشن درج کریں جہاں فائل کو محفوظ کیا جانا چاہیے۔
- Files of type ڈراپ ڈاؤن مینو سے، OBJexport کو منتخب کریں۔
- Export Selection پر کلک کریں۔
Substance Painter میں OBJ فائل امپورٹ اور تیار کریں
- File > New پر کلک کر کے ایک نیا Substance Painter پراجیکٹ بنائیں۔
- New project ڈائیلاگ میں، میش منتخب کرنے کے لیے Select پر کلک کریں۔
- وہ OBJ فائل منتخب کریں جسے آپ نے Maya سے ایکسپورٹ کیا ہے، اور پھر Open پر کلک کریں۔
- New project ونڈو میں، OK پر کلک کریں۔
- یہ چیک کر کے تصدیق کریں کہ آپ نے اپنا میش درست طریقے سے ایکسپورٹ کیا ہے کہ Texture set list پینل میں صرف ایک ٹیکسچر سیٹ موجود ہے۔
- اگر ایک سے زیادہ ٹیکسچر سیٹ ظاہر ہوتے ہیں، تو ایک سے زیادہ ٹیکسچر سیٹ دیکھیں۔
- Texture set settings پینل میں، چینل شامل کرنے کے لیے
+بٹن پر کلک کریں:
- درکار ہے: Ambient occlusion۔
- اختیاری: Emissive۔ اگر آپ کے ماڈل میں روشنی خارج کرنے والے اجزاء موجود ہوں تو یہ چینل شامل کریں۔
- اختیاری: Opacity۔ اگر آپ کے ماڈل میں شفاف ہونے والے اجزاء موجود ہوں تو یہ چینل شامل کریں۔
- Texture set settings پینل میں، Bake Mesh Maps پر کلک کریں۔
- ماڈل پر ٹیکسچر پینٹ کریں۔
ایک سے زیادہ ٹیکسچر سیٹ
جب آپ Substance Painter میں OBJ فائل امپورٹ کرتے ہیں، تو صرف ایک ٹیکسچر سیٹ ہونا چاہیے:

اگر ایک سے زیادہ ٹیکسچر سیٹ ظاہر ہو رہے ہیں، تو Maya سے میش (mesh) ایکسپورٹ کرتے وقت درج ذیل میں سے کوئی ایک غلطی ہوئی ہے:
- میش کو ایک ہی آبجیکٹ میں یکجا نہیں کیا گیا تھا۔
- میش پر ایک سے زیادہ ٹیکسچر تفویض کیے گئے تھے۔
اگر ایسا ہے، تو Maya سے اپنا ماڈل دوبارہ ایکسپورٹ کریں اور اس بات کو یقینی بنائیں کہ میش ایک ہی آبجیکٹ ہے اور اسے صرف ایک ہی ٹیکسچر تفویض کیا گیا ہے۔
Substance Painter سے glTF فائل ایکسپورٹ کریں
File > Export Textures پر کلک کریں۔
Config ڈراپ ڈاؤن مینو سے، glTF PBR Metal Roughness منتخب کریں۔
وہ مقام منتخب کریں جہاں آپ اپنے ٹیکسچرز محفوظ کرنا چاہتے ہیں۔
ٹیکسچر فائلوں کا سائز متعین کرنے کے لیے دستاویز کا سائز منتخب کریں۔
Export پر کلک کریں۔
ٹیکسچر فائلوں کو کمپریس کرنا
ماڈل ایکسپورٹ کر لینے کے بعد، آپ کے پاس درج ذیل فائلیں ہونی چاہئیں:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
glTF PBR Metal Roughness کنفیگریشن استعمال کرتے وقت، Substance Painter ٹیکسچر فائلوں کو صرف PNG فارمیٹ میں ایکسپورٹ کرتا ہے۔ ٹیکسچر فائلوں کو کمپریس کرنے اور کسی بھی ایسے ٹیکسچر کو JPG میں تبدیل کرنے پر غور کریں جنہیں الفا (alpha) چینل کی ضرورت نہیں ہے۔ اس سے فائل کا کُل سائز کم ہو جاتا ہے، اور چھوٹے سائز کی فائلوں سے ڈاؤن لوڈ کی رفتار تیز اور انٹرایکشنز ہموار ہو جاتے ہیں۔
اپنی فائل کا سائز 4 MB یا اس سے چھوٹا رکھنا بہترین ہے۔
GLB فائل بنائیں
- https://glb-packer-old.glitch.me/ پر جائیں۔
- جن فائلوں کو آپ نے Substance Painter سے ایکسپورٹ کیا ہے انہیں GLB Packer ویب پیج پر ڈریگ اینڈ ڈراپ کریں۔
آپ کے کمپیوٹر پر out.glb نامی ایک فائل ڈاؤن لوڈ کی جائے گی۔ ڈاؤن لوڈ مکمل ہونے کے بعد، آپ فائل کا نام تبدیل کر سکتے ہیں اور پھر اسے Shopify پر اپ لوڈ کر سکتے ہیں۔