Maya ve Substance Painter kullanarak GLB dosyaları oluşturma

Shopify yöneticisindeki bir ürüne eklenebilecek bir GLB dosyasını dışa aktarmak için Maya ve Substance Painter'ı kullanabilirsiniz. 3B modeller, müşterilerin ürünleri görselleştirmesine yardımcı olabilir. Bu da güveni artırır ve iadeleri azaltır.

Modelinizi Maya'da dışa aktarmaya hazırlama

Modelinizi dışa aktarmaya hazırlamak için tek bir mesh olduğundan ve tek bir materyalin uygulandığından emin olmanız gerekir.

Adımlar:

  1. Modelinizi, Dosya > İçe Aktar... bölümüne gidip 3B dosyanızı seçerek ve ardından İçe Aktar'a tıklayarak Maya'ya aktarın.
  2. Mesh'inizi tek bir nesnede birleştirmek için Mesh > Birleştir'e tıklayın.
  3. Modeli 0-1 UV alanına yayın. Hiçbir UV'nin çakışmadığından emin olun:
    UV Düzenleyicisi'ni kullanarak UV'leri X ve Y eksenlerinde 0 ile 1 arasına yerleştirin.
  4. Modele bir Phong materyali uygulayın:
    1. Fare imleciniz modelin üzerindeyken sağ tıklayıp basılı tutun ve ardından Yeni Materyal Ata... seçeneğini belirleyin.
    2. İletişim kutusundan Phong'u seçin.

Mesh'i Maya'dan dışa aktarma

  1. Mesh'in tamamını seçin ve ardından Dosya > Seçimi Dışa Aktar... seçeneğine tıklayın.
  2. Bir dosya adı ve dosyanın kaydedileceği konumu girin.
  3. Dosya türü açılır menüsünden OBJexport'u seçin.
  4. Seçimi Dışa Aktar'a tıklayın.

OBJ dosyasını Substance Painter'a aktarma ve hazırlama

  1. Dosya > Yeni'ye tıklayarak yeni bir Substance Painter projesi oluşturun.
  2. Yeni proje iletişim kutusunda, bir mesh seçmek için Seç'e tıklayın.
  3. Maya'dan dışa aktardığınız OBJ dosyasını seçin ve ardından 'a tıklayın.
  4. Yeni proje penceresinde Tamam'a tıklayın.
  5. Mesh'inizi doğru bir şekilde dışa aktardığınızı doğrulamak için Doku seti listesi panelinde yalnızca bir doku seti olup olmadığını kontrol edin.
  6. Doku seti ayarları panelinde, + kanalları ekleme düğmesi:
    + düğmesi, Kanallar başlığının yanındadır. Düğme, kullanılabilir olan ek kanalları gösteren bir açılır menü açar.
    • Gerekli: Ortam tıkanması.
    • İsteğe bağlı: Yayıcı. Modelinizde ışık yayacak bileşenler varsa bu kanalı ekleyin.
    • İsteğe bağlı: Opaklık. Modelinizde şeffaf olacak bileşenler varsa bu kanalı ekleyin.
  7. Doku seti ayarları panelinde, Mesh Haritalarını Pişir'e tıklayın.
  8. Dokuları modelin üzerine boyayın.

Birden fazla doku seti

OBJ dosyasını Substance Painter'a aktardığınızda yalnızca bir doku seti olmalıdır:

Doku kümeleri, Doku kümesi listesi panelinde listelenir.

Birden fazla doku kümesi görüntüleniyorsa bu, mesh Maya'dan dışa aktarılırken aşağıdakilerden birinin yanlış olduğu anlamına gelir:

  • Mesh tek bir nesnede birleştirilmemiş.
  • Mesh'e birden fazla doku atanmış.

Durum buysa modelinizi Maya'dan yeniden dışa aktarın ve mesh'in tek bir nesne olduğundan ve kendisine atanmış yalnızca tek bir dokusu olduğundan emin olun.

glTF dosyasını Substance Painter'dan dışa aktarma

  1. Dosya > Dokuları Dışa Aktar'a tıklayın.

  2. Yapılandırma açılır menüsünden glTF PBR Metal Roughness'ı seçin.

  3. Dokularınızı kaydetmek istediğiniz konumu seçin.

  4. Doku dosyalarının ne kadar büyük olacağını belirlemek için bir belge boyutu seçin.

  5. Dışa Aktar'a tıklayın.

Doku dosyalarını sıkıştırma

Modeli dışa aktardığınızda aşağıdaki dosyalara sahip olursunuz:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

glTF PBR Metal Roughness yapılandırmasını kullanırken Substance Painter, doku dosyalarını yalnızca PNG biçiminde dışa aktarır. Doku dosyalarını sıkıştırmayı ve alfa kanalına ihtiyaç duymayan dokuları JPG'ye dönüştürmeyi düşünün. Bu, toplam dosya boyutunu azaltır. Daha küçük dosya boyutları ise daha hızlı indirme hızları ve daha sorunsuz etkileşimler sağlar.

Dosya boyutunuzu 4 MB veya daha küçük tutmanız en iyisidir.

GLB dosyası oluşturma

  1. https://glb-packer-old.glitch.me/ adresini ziyaret edin.
  2. Substance Painter'dan dışa aktardığınız dosyaları GLB Packer web sayfasına sürükleyip bırakın.

Bilgisayarınıza out.glb adlı bir dosya indirilir. İndirme işlemi tamamlandıktan sonra dosyayı yeniden adlandırabilir ve Shopify'a yükleyebilirsiniz.