การสร้างไฟล์ GLB โดยใช้ Maya และ Substance Painter

คุณสามารถใช้ Maya และ Substance Painter เพื่อส่งออกไฟล์ GLB ที่สามารถเพิ่มไปยังสินค้าในส่วนผู้ดูแล Shopify ได้ โมเดล 3D ช่วยให้ลูกค้าเห็นภาพสินค้าได้ ซึ่งจะช่วยเพิ่มความเชื่อมั่นและลดการคืนสินค้า

เตรียมโมเดลของคุณให้พร้อมสำหรับการส่งออกใน Maya

หากต้องการเตรียมโมเดลของคุณให้พร้อมสำหรับการส่งออก คุณต้องตรวจสอบให้แน่ใจว่าเป็นเมชเดียวและมีการใช้วัสดุเพียงชิ้นเดียว

ขั้นตอน

  1. นำเข้าโมเดลของคุณไปยัง Maya โดยไปที่ File > Import... เลือกไฟล์ 3D ของคุณ จากนั้นคลิกที่ Import
  2. คลิก Mesh > Combine เพื่อรวมเมชของคุณให้เป็นอ็อบเจกต์เดียว
  3. คลี่โมเดลลงในพื้นที่ UV 0-1 ตรวจสอบให้แน่ใจว่าไม่มี UV ที่ทับซ้อนกัน
    ใช้ UV Editor เพื่อจัดเรียง UV ให้อยู่ระหว่าง 0 ถึง 1 บนแกน X และ Y
  4. ใช้วัสดุ Phong กับโมเดล
    1. เมื่อเคอร์เซอร์เมาส์ของคุณอยู่เหนือโมเดล ให้คลิกขวาค้างไว้ จากนั้นเลือก Assign New Material...
    2. จากกล่องโต้ตอบ ให้เลือก Phong

ส่งออกเมชจาก Maya

  1. เลือกเมชทั้งหมด จากนั้นคลิก File > Export Selection...
  2. ป้อนชื่อไฟล์และตำแหน่งที่ตั้งที่ต้องการบันทึกไฟล์
  3. จากเมนูดรอปดาวน์Files of type ให้เลือก OBJexport
  4. คลิก Export Selection

นำเข้าและเตรียมไฟล์ OBJ ใน Substance Painter

  1. สร้างโปรเจกต์ Substance Painter ใหม่โดยคลิกที่ File > New
  2. ในกล่องโต้ตอบ New project ให้คลิกที่ Select เพื่อเลือกเมช
  3. เลือกไฟล์ OBJ ที่คุณส่งออกจาก Maya จากนั้นคลิก Open
  4. ในหน้าต่าง New project ให้คลิก OK
  5. ตรวจสอบว่าคุณส่งออกเมชอย่างถูกต้อง โดยตรวจดูว่ามีชุดเท็กซ์เจอร์เพียงชุดเดียวในแผง Texture set list แผง
  6. ในแผง Texture set settings ให้คลิกปุ่ม + เพื่อเพิ่มช่องทาง
    ปุ่ม + อยู่ถัดจากหัวข้อ Channels ปุ่มนี้จะเปิดเมนูดรอปดาวน์ที่แสดงช่องทางเพิ่มเติมที่พร้อมใช้งาน
    • จำเป็น: Ambient occlusion
    • ไม่บังคับ: Emissive เพิ่มช่องทางนี้หากโมเดลของคุณมีส่วนประกอบที่จะปล่อยแสง
    • ไม่บังคับ: Opacity เพิ่มช่องทางนี้หากโมเดลของคุณมีส่วนประกอบที่จะโปร่งใส
  7. ในแผง Texture set settings ให้คลิกที่ Bake Mesh Maps
  8. เพนต์เท็กซ์เจอร์ลงบนโมเดล

ชุดเท็กซ์เจอร์หลายชุด

เมื่อคุณนำเข้าไฟล์ OBJ ไปยัง Substance Painter ควรมีชุดเท็กซ์เจอร์เพียงชุดเดียว

ชุดพื้นผิวจะแสดงอยู่ในแผงรายการชุดพื้นผิว

หากมีการแสดงชุดพื้นผิวมากกว่าหนึ่งชุด แสดงว่ามีข้อผิดพลาดอย่างใดอย่างหนึ่งต่อไปนี้เกิดขึ้นเมื่อส่งออกเมชจาก Maya:

  • เมชไม่ได้ถูกรวมเป็นอ็อบเจกต์เดียว
  • เมชมีการกำหนดพื้นผิวมากกว่าหนึ่งแบบ

หากเป็นกรณีนี้ ให้ส่งออกโมเดลของคุณจาก Maya อีกครั้ง และตรวจสอบให้แน่ใจว่าเมชเป็นอ็อบเจกต์เดียวและมีการกำหนดพื้นผิวเพียงแบบเดียว

ส่งออกไฟล์ glTF จาก Substance Painter

  1. คลิกที่ ไฟล์ > ส่งออกพื้นผิว

  2. จากเมนูดรอปดาวน์ Config ให้เลือก glTF PBR Metal Roughness

  3. เลือกตำแหน่งที่ตั้งที่คุณต้องการบันทึกพื้นผิว

  4. เลือกขนาดเอกสารเพื่อกำหนดขนาดของไฟล์พื้นผิว

  5. คลิกที่ ส่งออก

การบีบอัดไฟล์พื้นผิว

เมื่อคุณส่งออกโมเดลแล้ว คุณควรจะมีไฟล์ต่อไปนี้:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

เมื่อใช้การกำหนดค่า glTF PBR Metal Roughness นั้น Substance Painter จะส่งออกไฟล์พื้นผิวในรูปแบบ PNG เท่านั้น คุณควรพิจารณาบีบอัดไฟล์พื้นผิวและแปลงพื้นผิวใดๆ ที่ไม่จำเป็นต้องใช้ช่องอัลฟา (alpha channel) ให้เป็น JPG ซึ่งจะช่วยลดขนาดไฟล์โดยรวม และขนาดไฟล์ที่เล็กลงจะทำให้ดาวน์โหลดได้เร็วขึ้นและมีการโต้ตอบที่ราบรื่นยิ่งขึ้น

ทางที่ดีที่สุดคือการรักษาขนาดไฟล์ของคุณให้ไม่เกิน 4 MB

สร้างไฟล์ GLB

  1. ไปที่ https://glb-packer-old.glitch.me/
  2. ลากและปล่อยไฟล์ที่คุณส่งออกจาก Substance Painter ไปยังหน้าเว็บ GLB Packer

ไฟล์ชื่อ out.glb จะถูกดาวน์โหลดไปยังคอมพิวเตอร์ของคุณ หลังจากดาวน์โหลดเสร็จสิ้น คุณสามารถเปลี่ยนชื่อไฟล์แล้วจึงอัปโหลดไปยัง Shopify