Skapa GLB-filer med Maya och Substance Painter
Du kan använda Maya och Substance Painter för att exportera en GLB-fil som kan läggas till för en produkt i Shopify admin. 3D-modeller kan hjälpa kunder att visualisera produkter, vilket kan öka förtroendet och minska antalet returer.
På den här sidan
Förbered din modell för export i Maya
För att förbereda din modell för export måste du se till att den är en enda mesh och att den har ett enda material applicerat.
Steg:
- Importera din modell till Maya genom att gå till File > Import..., välja din 3D-fil och sedan klicka på Import.
- Klicka på Mesh > Combine för att kombinera din mesh till ett enda objekt.
- Veckla ut modellen i ett 0 – 1 UV-utrymme. Se till att inga UV:er överlappar:

- Applicera ett Phong-material på modellen:
- Håll muspekaren över modellen, högerklicka och håll ned och välj sedan Assign New Material...
- Välj Phong i dialogrutan.
Exportera meshen från Maya
- Välj hela meshen och klicka sedan på File > Export Selection...
- Ange ett filnamn och den plats där filen ska sparas.
- Välj OBJexport i rullgardinsmenyn Files of type.
- Klicka på Export Selection.
Importera och förbered OBJ-filen i Substance Painter
- Skapa ett nytt Substance Painter-projekt genom att klicka på File > New.
- Klicka på Select i dialogrutan New project för att välja en mesh.
- Välj den OBJ-fil som du exporterade från Maya och klicka sedan på Open.
- Klicka på OK i fönstret New project.
- Verifiera att du har exporterat din mesh korrekt genom att kontrollera att det bara finns en texturuppsättning i panelen Texture set list .
- Om fler än en texturuppsättning visas, se Flera texturuppsättningar.
- I panelen Texture set settings , klicka på
+knappen för att lägga till kanaler:
- Krävs: Ambient occlusion.
- Valfritt: Emissive. Lägg till den här kanalen om din modell har komponenter som kommer att avge ljus.
- Valfritt: Opacity. Lägg till den här kanalen om din modell har komponenter som kommer att vara genomskinliga.
- Klicka på Bake Mesh Maps i panelen Texture set settings.
- Måla texturer på modellen.
Flera texturuppsättningar
När du importerar OBJ-filen till Substance Painter ska det bara finnas en texturuppsättning:

Om mer än en texturuppsättning visas, var något av följande fel när nätet exporterades från Maya:
- Nätet kombinerades inte till ett enda objekt.
- Mer än en textur hade tilldelats nätet.
Om så är fallet, exportera din modell från Maya igen och se till att nätet är ett enda objekt och att det bara har en enda textur tilldelad.
Exportera glTF-filen från Substance Painter
Klicka på Arkiv > Exportera texturer.
Välj glTF PBR Metal Roughness i rullgardinsmenyn Konfiguration.
Välj den plats där du vill spara dina texturer.
Välj en dokumentstorlek för att avgöra hur stora texturfilerna kommer att vara.
Klicka på Exportera.
Komprimera texturfiler
När du har exporterat modellen bör du ha följande filer:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
När du använder konfigurationen glTF PBR Metal Roughness exporterar Substance Painter endast texturfiler i PNG-format. Överväg att komprimera texturfilerna och konvertera alla texturer som inte behöver en alfakanal till JPG. Detta minskar den totala filstorleken och mindre filstorlekar ger snabbare nedladdningshastigheter och smidigare interaktioner.
Det är bäst att hålla filstorleken på 4 MB eller mindre.
Skapa en GLB-fil
- Besök https://glb-packer-old.glitch.me/.
- Dra och släpp filerna som du exporterade från Substance Painter på webbsidan GLB Packer.
En fil med namnet out.glb kommer att laddas ner till din dator. När nedladdningen är klar kan du byta namn på filen och sedan ladda upp den till Shopify.