Skapa GLB-filer med Blender och Substance Painter
Från och med version 2.8 kan Blender exportera GLB-filer som kan läggas till en produkt i Shopify admin. Mer information finns i Blender-manualen.
För äldre versioner av Blender kan du kombinera Blender och Substance Painter för att exportera en GLB-fil.
På den här sidan
Förbered din modell för export i Blender
För att förbereda din modell för export måste du se till att den består av en enda mesh och har en enda textur.
Steg:
- Klicka på File > Import och välj sedan rätt filformat för din modell.
- Välj din modellfil och klicka sedan på Import.
- Håll ner
SHIFT, högerklicka på varje objekt i din scen och tryck sedan påCtrl+Jför att sammanfoga dem till en enda mesh. - UV-mappa modellen till 0-1 UV-utrymme. Se till att inga UV:er överlappar varandra:

- Klicka på materialikonen i egenskapsredigeraren.
- Klicka på
+-knappen för att lägga till en ny materialplats:
- Klicka på Nytt.
Exportera nätet från Blender
- Klicka på Arkiv > Exportera > FBX (.fbx).
- Ange sökvägen dit du vill exportera filen.
- Se till att du använder följande exportinställningar:

- Klicka på Exportera FBX.
Importera och förbered FBX-filen i Substance Painter
- Skapa ett nytt Substance Painter-projekt genom att klicka på Arkiv > Nytt.
- Klicka på Välj i dialogrutan Nytt projekt för att välja ett nät.
- Välj den FBX-fil som du exporterade från Blender och klicka sedan på Öppna.
- Klicka på OK i fönstret Nytt projekt.
- Verifiera att du har exporterat nätet korrekt genom att kontrollera att det bara finns en texturuppsättning i panelen Lista med texturuppsättningar .
- Om fler än en texturuppsättning visas, se Flera texturuppsättningar.
- I panelen Inställningar för texturuppsättning klickar du på
+knappen för att lägga till kanaler:
- Obligatorisk: Omgivande ocklusion.
- Valfritt: Emissiv. Lägg till den här kanalen om din modell har komponenter som avger ljus.
- Valfritt: Opacitet. Lägg till den här kanalen om din modell har komponenter som är genomskinliga.
- Klicka på Baka nätmappningar i panelen Inställningar för texturuppsättning.
- Måla texturer på modellen.
Flera texturuppsättningar
När du importerar FBX-filen till Substance Painter ska det bara finnas en texturuppsättning:

Om fler än en texturuppsättning visas var något av följande fel när nätet exporterades från Blender:
- Nätet kombinerades inte till ett enda objekt.
- Nätet hade mer än en textur tilldelad.
Om så är fallet exporterar du din modell från Blender igen och ser till att nätet är ett enda objekt och endast har en enda textur tilldelad.
Exportera glTF-filen från Substance Painter
Klicka på Arkiv > Exportera texturer.
Välj glTF PBR Metal Roughness i rullgardinsmenyn Konfiguration.
Välj den plats där du vill spara dina texturer.
Välj en dokumentstorlek för att avgöra hur stora texturfilerna kommer att bli.
Klicka på Exportera.
Komprimera texturfiler
När du har exporterat modellen bör du ha följande filer:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
När du använder konfigurationen glTF PBR Metal Roughness exporterar Substance Painter endast texturfiler i PNG-format. Överväg att komprimera texturfilerna och konvertera alla texturer som inte behöver en alfakanal till jpg. Detta minskar den totala filstorleken och mindre filstorlekar möjliggör snabbare nedladdningshastigheter och smidigare interaktioner.
Det är bäst att hålla filstorleken på 4 MB eller mindre.
Skapa en GLB-fil
- Besök https://glb-packer-old.glitch.me/.
- Dra och släpp filerna som du exporterade från Substance Painter på webbsidan GLB Packer.
En fil med namnet out.glb kommer att laddas ner till din dator. När nedladdningen är klar kan du byta namn på filen och sedan ladda upp den till Shopify.