Skapa GLB-filer med 3ds Max och Substance Painter
Du kan använda 3ds Max och Substance Painter för att exportera en GLB-fil som kan läggas till en produkt i Shopify-admin. 3D-modeller kan hjälpa kunder att visualisera produkter, vilket kan öka förtroendet och minska antalet returer.
På den här sidan
Förbered din modell för export i 3ds Max
För att förbereda din modell för export måste du se till att den är ett enda nät och att den har ett enda material applicerat på sig.
Steg:
- Klicka på Arkiv > Importera ... > Importera ....
- Välj din modellfil och klicka sedan på Öppna.
- I dialogrutan Alternativ för OBJ-import markerar du Importera som ett enda nät.
- Klicka på Importera.
- Veckla ut modellen i 0-1-rymden. Se till att inga UV-värden överlappar varandra:

- Applicera ett enda material på hela modellen.
Exportera nätet från 3ds Max
- Klicka på Arkiv > Exportera > Exportera ...
- Ange ett filnamn och den plats där du vill exportera modellen.
- I rullgardinsmenyn Spara som väljer du OBJ-Export (.OBJ).
- Klicka på Spara.
- I dialogrutan Alternativ för OBJ-export lämnar du standardalternativen som de är och klickar på Exportera.
Importera och förbered OBJ-filen i Substance Painter
- Skapa ett nytt Substance Painter-projekt genom att klicka på Arkiv > Nytt.
- Klicka på Select i dialogrutan New project för att välja en mesh.
- Välj den OBJ-fil som du exporterade från 3ds Max och klicka sedan på Open.
- Klicka på OK i fönstret New project.
- Verifiera att meshen exporterades korrekt genom att kontrollera att det bara finns en texture set i Texture set list -panelen.
- Om fler än en texture set visas, se Flera texture sets.
- I Texture set settings -panelen klickar du på
+-knappen för att lägga till kanaler:
- Obligatorisk: Ambient occlusion.
- Valfritt: Emissive. Lägg till den här kanalen om din modell har komponenter som ska avge ljus.
- Valfritt: Opacity. Lägg till den här kanalen om din modell har komponenter som ska vara genomskinliga.
- Klicka på Bake Mesh Maps i panelen Texture set settings.
- Måla texturer på modellen.
Flera texture sets
När du importerar OBJ-filen till Substance Painter ska det bara finnas en texture set:

Om fler än en texture set visas var något av följande fel när meshen exporterades från 3ds Max:
- Meshen kombinerades inte till ett enda objekt.
- Meshen hade mer än en textur tilldelad.
Om så är fallet, exportera din modell från 3ds Max igen och se till att meshen är ett enda objekt och att den bara har en enda textur tilldelad.
Exportera glTF-filen från Substance Painter
Klicka på File > Export Textures.
Välj glTF PBR Metal Roughness från rullgardinsmenyn Config.
Välj den plats där du vill spara dina texturer.
Välj en dokumentstorlek för att avgöra hur stora texturfilerna kommer att bli.
Klicka på Export.
Komprimera texturfiler
När du har exporterat modellen bör du ha följande filer:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
När konfigurationen glTF PBR Metal Roughness används exporterar Substance Painter endast texturfiler i PNG-format. Överväg att komprimera texturfilerna och konvertera alla texturer som inte behöver en alfakanal till jpg. Detta minskar den totala filstorleken och mindre filstorlekar möjliggör snabbare nedladdningshastigheter och smidigare interaktioner.
Det är bäst att hålla filstorleken på 4 MB eller mindre.
Skapa en GLB-fil
- Besök https://glb-packer-old.glitch.me/.
- Dra och släpp filerna som du exporterade från Substance Painter på GLB Packer-webbsidan.
En fil med namnet out.glb kommer att laddas ner till din dator. När nedladdningen är klar kan du byta namn på filen och sedan ladda upp den till Shopify.