Ustvarjanje datotek GLB s programoma Maya in Substance Painter
Programa Maya in Substance Painter lahko uporabite za izvoz datoteke GLB, ki jo lahko dodate izdelku v skrbniku Shopify. 3D-modeli lahko strankam pomagajo, da si vizualizirajo izdelke, kar lahko poveča zaupanje in zmanjša število vračil.
Na tej strani
Priprava modela za izvoz v programu Maya
Da bi model pripravili na izvoz, se morate prepričati, da je to ena sama mreža, ki ji je dodeljen en sam material.
Koraki:
- Uvozite model v program Maya tako, da odprete File > Import..., izberete svojo 3D-datoteko in nato kliknete Import.
- Kliknite Mesh > Combine, da združite mrežo v en sam predmet.
- Razvijte model v UV-prostor od 0 do 1. Prepričajte se, da se nobene UV-koordinate ne prekrivajo:

- Modelu dodelite material Phong:
- Kazalec miške pomaknite na model, pritisnite in zadržite desni gumb miške ter nato izberite Assign New Material...
- V pogovornem oknu izberite Phong.
Izvoz mreže iz programa Maya
- Izberite celotno mrežo in nato kliknite File > Export Selection...
- Vnesite ime datoteke in lokacijo, kamor želite shraniti datoteko.
- V spustnem meniju Files of type izberite OBJexport.
- Kliknite Export Selection.
Uvoz in priprava datoteke OBJ v programu Substance Painter
- Ustvarite nov projekt Substance Painter tako, da kliknete File > New.
- V pogovornem oknu New project kliknite Select, da izberete mrežo.
- Izberite datoteko OBJ, ki ste jo izvozili iz programa Maya, in nato kliknite Open.
- V oknu New project kliknite OK.
- Preverite, ali ste pravilno izvozili mrežo, tako da se prepričate, da je prisoten samo en niz tekstur na plošči Texture set list .
- Če je prikazan več kot en niz tekstur, glejte Več nizov tekstur.
- Na plošči Texture set settings kliknite gumb
+, da dodate kanale:
- Obvezno: Ambient occlusion.
- Izbirno: Emissive. Dodajte ta kanal, če ima vaš model komponente, ki bodo oddajale svetlobo.
- Izbirno: Opacity. Dodajte ta kanal, če ima vaš model komponente, ki bodo prozorne.
- Na plošči Texture set settings kliknite Bake Mesh Maps.
- Model poslikajte s teksturami.
Več nizov tekstur
Ko uvozite datoteko OBJ v program Substance Painter, mora biti na voljo le en niz tekstur:

Če je prikazan več kot en niz tekstur, je bilo pri izvozu mreže iz programa Maya nekaj narobe:
- Mreža ni bila združena v en sam predmet.
- Mreži je bila dodeljena več kot ena tekstura.
V tem primeru znova izvozite model iz programa Maya in se prepričajte, da je mreža en sam predmet, ki mu je dodeljena samo ena tekstura.
Izvoz datoteke glTF iz programa Substance Painter
Kliknite File > Export Textures.
V spustnem meniju Config izberite glTF PBR Metal Roughness.
Izberite lokacijo, kamor želite shraniti svoje teksture.
Izberite velikost dokumenta, da določite, kako velike bodo datoteke s teksturami.
Kliknite Export.
Stiskanje datotek s teksturami
Ko izvozite model, bi morali imeti naslednje datoteke:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Pri uporabi konfiguracije glTF PBR Metal Roughness program Substance Painter izvozi datoteke s teksturami samo v formatu PNG. Priporočamo, da datoteke s teksturami stisnete in vse teksture, ki ne potrebujejo kanala alfa, pretvorite v format JPG. S tem zmanjšate skupno velikost datoteke, manjše velikosti datotek pa omogočajo hitrejši prenos in bolj tekoče interakcije.
Najbolje je, da velikost vaše datoteke ne presega 4 MB.
Ustvarjanje datoteke GLB
- Obiščite https://glb-packer-old.glitch.me/.
- Datoteke, ki ste jih izvozili iz programa Substance Painter, povlecite in spustite na spletno stran GLB Packer.
Na vaš računalnik se bo prenesla datoteka z imenom out.glb. Ko je prenos končan, lahko datoteko preimenujete in jo naložite v Shopify.