Ustvarjanje datotek GLB s programoma 3ds Max in Substance Painter
S programoma 3ds Max in Substance Painter lahko izvozite datoteko GLB, ki jo nato v skrbniku Shopify dodate izdelku. 3D-modeli strankam pomagajo pri vizualizaciji izdelkov, kar lahko poveča zaupanje in zmanjša število vračil.
Na tej strani
Pripravite model za izvoz v programu 3ds Max
Če želite model pripraviti za izvoz, se morate prepričati, da je to ena mreža in da je nanjo uporabljen en sam material.
Koraki:
- Kliknite Datoteka > Uvozi ... > Uvozi ...
- Izberite datoteko modela in nato kliknite Odpri.
- V pogovornem oknu Možnosti uvoza OBJ potrdite možnost Uvozi kot posamezno mrežo.
- Kliknite Uvozi.
- Razvijte model v prostor od 0 do 1. Prepričajte se, da se UV-ji ne prekrivajo:

- Uporabite en sam material za celoten model.
Izvozite mrežo iz programa 3ds Max
- Kliknite Datoteka > Izvozi > Izvozi ...
- Vnesite ime datoteke in lokacijo, kamor želite izvoziti model.
- V spustnem meniju Shrani kot vrsto izberite OBJ-Export (.OBJ).
- Kliknite Shrani.
- V pogovornem oknu Možnosti izvoza OBJ pustite privzete možnosti nespremenjene in kliknite Izvozi.
Uvozite in pripravite datoteko OBJ v programu Substance Painter
- Ustvarite nov projekt v programu Substance Painter tako, da kliknete Datoteka > Novo.
- V pogovornem oknu Nov projekt kliknite Izberi, da izberete mrežo.
- Izberite datoteko OBJ, ki ste jo izvozili iz programa 3ds Max, in nato kliknite Odpri.
- V oknu Nov projekt kliknite V redu.
- Prepričajte se, da ste pravilno izvozili mrežo, tako da preverite, ali je samo en nabor tekstur na plošči Seznam naborov tekstur .
- Če je prikazanih več naborov tekstur, glejte Več naborov tekstur.
- Na plošči Nastavitve nabora tekstur kliknite gumb
+, da dodate kanale:
- Obvezno: Ambient occlusion.
- Izbirno: Emissive. Ta kanal dodajte, če ima vaš model komponente, ki bodo oddajale svetlobo.
- Izbirno: Opacity. Ta kanal dodajte, če ima vaš model komponente, ki bodo prosojne.
- Na plošči Nastavitve nabora tekstur kliknite Bake Mesh Maps.
- Na model narišite teksture.
Več naborov tekstur
Ko uvozite datoteko OBJ v program Substance Painter, mora biti na voljo samo en nabor tekstur:

Če je prikazan več kot en nabor tekstur, je pri izvozu mreže iz programa 3ds Max prišlo do ene od naslednjih napak:
- Mreža ni bila združena v en sam predmet.
- Mreži je bila dodeljena več kot ena tekstura.
Če je tako, znova izvozite model iz programa 3ds Max in poskrbite, da je mreža en sam predmet ter ima dodeljeno le eno teksturo.
Izvozite datoteko glTF iz programa Substance Painter
Kliknite File > Export Textures.
V spustnem meniju Config izberite glTF PBR Metal Roughness.
Izberite lokacijo, kamor želite shraniti teksture.
Izberite velikost dokumenta, da določite, kako velike bodo datoteke tekstur.
Kliknite Export.
Stiskanje datotek tekstur
Ko izvozite model, bi morali imeti naslednje datoteke:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Pri uporabi konfiguracije glTF PBR Metal Roughness program Substance Painter izvozi datoteke tekstur samo v formatu PNG. Razmislite o stiskanju datotek tekstur in pretvorbi vseh tekstur, ki ne potrebujejo kanala alfa, v format JPG. To zmanjša skupno velikost datoteke, manjše velikosti datotek pa omogočajo hitrejši prenos in bolj tekoče interakcije.
Najbolje je, da velikost datoteke ohranite pri 4 MB ali manj.
Ustvarite datoteko GLB
- Obiščite https://glb-packer-old.glitch.me/.
- Datoteke, ki ste jih izvozili iz programa Substance Painter, povlecite in spustite na spletno stran GLB Packer.
Datoteka z imenom out.glb se bo prenesla v vaš računalnik. Ko je prenos končan, lahko datoteko preimenujete in jo nato naložite v Shopify.