Vytváranie súborov GLB pomocou programov Maya a Substance Painter

Pomocou programov Maya a Substance Painter môžete exportovať súbor GLB, ktorý je možné pridať k produktu v administrátorovi Shopify. 3D modely pomáhajú zákazníkom vizualizovať produkty, čo môže zvýšiť ich dôveru a znížiť počet vrátení.

Príprava modelu na export v programe Maya

Ak chcete pripraviť model na export, uistite sa, že ide o jednu sieť, na ktorú je použitý jeden materiál.

Postup:

  1. Importujte model do programu Maya: prejdite na File > Import..., vyberte svoj 3D súbor a kliknite na Import.
  2. Kliknite na Mesh > Combine, čím sieť zlúčite do jedného objektu.
  3. Rozviňte model do UV priestoru 0 – 1. Uistite sa, že sa žiadne UV neprekrývajú:
    Pomocou editora UV rozložte UV medzi 0 a 1 na osiach X a Y.
  4. Aplikujte na model materiál Phong:
    1. Umiestnite kurzor myši na model, kliknite a podržte pravé tlačidlo a vyberte možnosť Assign New Material...
    2. V dialógovom okne vyberte položku Phong.

Export siete z programu Maya

  1. Vyberte celú sieť a kliknite na File > Export Selection...
  2. Zadajte názov súboru a umiestnenie, kam sa má súbor uložiť.
  3. V rozbaľovacej ponuke Files of type vyberte možnosť OBJexport.
  4. Kliknite na Export Selection.

Import a príprava súboru OBJ v programe Substance Painter

  1. Vytvorte nový projekt v programe Substance Painter kliknutím na File > New.
  2. V dialógovom okne New project kliknite na Select a vyberte sieť.
  3. Vyberte súbor OBJ, ktorý ste exportovali z programu Maya, a kliknite na Open.
  4. V okne New project kliknite na OK.
  5. Overte, či ste sieť exportovali správne, a to kontrolou, či sa v paneli Texture set list nachádza len jedna súprava textúr.
  6. V paneli Texture set settings kliknite na tlačidlo + a pridajte kanály:
    Tlačidlo + sa nachádza vedľa nadpisu Channels. Tlačidlo otvorí rozbaľovaciu ponuku, v ktorej sa zobrazia ďalšie dostupné kanály.
    • Povinné: Ambient occlusion.
    • Voliteľné: Emissive. Tento kanál pridajte, ak má váš model komponenty, ktoré budú vyžarovať svetlo.
    • Voliteľné: Opacity. Tento kanál pridajte, ak má váš model komponenty, ktoré budú priehľadné.
  7. V paneli Texture set settings kliknite na Bake Mesh Maps.
  8. Namaľujte textúry na model.

Viacero súprav textúr

Po importe súboru OBJ do programu Substance Painter by mala existovať iba jedna súprava textúr:

Súpravy textúr sú uvedené v paneli Texture set list.

Ak sa zobrazuje viacero súprav textúr, pri exporte siete z programu Maya došlo k jednej z nasledujúcich chýb:

  • Sieť nebola zlúčená do jedného objektu.
  • Sieti bola priradená viac ako jedna textúra.

V takom prípade znova exportujte model z programu Maya a uistite sa, že sieť je jeden objekt a má priradenú iba jednu textúru.

Export súboru glTF z programu Substance Painter

  1. Kliknite na File > Export Textures.

  2. V rozbaľovacej ponuke Config vyberte možnosť glTF PBR Metal Roughness.

  3. Vyberte umiestnenie, kam chcete textúry uložiť.

  4. Výberom veľkosti dokumentu určite, aké veľké budú súbory textúr.

  5. Kliknite na Export.

Komprimácia súborov textúr

Po exportovaní modelu by ste mali mať k dispozícii tieto súbory:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Pri použití konfigurácie glTF PBR Metal Roughness exportuje Substance Painter súbory textúr iba vo formáte PNG. Zvážte komprimáciu súborov textúr a konverziu všetkých textúr, ktoré nepotrebujú alfa kanál, do formátu JPG. Zníži sa tým celková veľkosť súboru. Menšie veľkosti súborov umožňujú vyššie rýchlosti sťahovania a plynulejšie interakcie.

Odporúčame udržiavať veľkosť súboru na úrovni maximálne 4 MB.

Vytvorenie súboru GLB

  1. Prejdite na adresu https://glb-packer-old.glitch.me/.
  2. Pretiahnite súbory, ktoré ste exportovali zo softvéru Substance Painter, na webovú stránku GLB Packer.

Súbor s názvom out.glb sa stiahne do vášho počítača. Po stiahnutí môžete súbor premenovať a potom ho nahrať do služby Shopify.