Vytváranie súborov GLB pomocou softvérov Blender a Substance Painter

Od verzie 2.8 dokáže Blender exportovať súbory GLB, ktoré sa dajú pridať k produktu v administrátorovi Shopify. Ďalšie informácie nájdete v príručke k softvéru Blender.

V prípade starších verzií softvéru Blender môžete na export súboru GLB skombinovať Blender a Substance Painter.

Príprava modelu na export v softvéri Blender

Ak chcete pripraviť model na export, uistite sa, že ide o jednu sieť a že má aplikovanú len jednu textúru.

Kroky:

  1. Kliknite na Súbor > Importovať a potom vyberte správny formát súboru pre svoj model.
  2. Vyberte súbor modelu a potom kliknite na Importovať.
  3. Podržte kláves SHIFT, kliknite pravým tlačidlom myši na každý objekt v scéne a potom ich stlačením kombinácie klávesov Ctrl + J spojte do jednej siete.
  4. Rozviňte model do UV priestoru 0-1. Uistite sa, že sa žiadne UV neprekrývajú:
    V editore UV/obrázkov skontrolujte, či sú všetky UV rozložené na mriežke.
  5. V editore Vlastnosti kliknite na ikonu materiálov.
  6. Kliknite na tlačidlo + a pridajte nový slot materiálu:
    Tlačidlo „Pridať slot materiálu“ sa nachádza blízko hornej časti tably „Materiál“.
  7. Kliknite na Nové.

Export siete zo softvéru Blender

  1. Kliknite na Súbor > Exportovať > FBX (.fbx).
  2. Zadajte cestu pre export súboru.
  3. Uistite sa, že používate nasledujúce nastavenia exportu:
    Verzia: FBX 7.4 binary. Mierka: 1.0. Aplikovať zmeny mierky: All Local. Vpred: -Z Forward. Nahor: Y Up. Režim cesty: Auto. Dávkový režim: Vypnuté.
  4. Kliknite na Exportovať FBX.

Import a príprava súboru FBX v softvéri Substance Painter

  1. Kliknutím na Súbor > Nový vytvorte nový projekt v softvéri Substance Painter.
  2. V dialógovom okne Nový projekt kliknite na Vybrať a zvoľte sieť.
  3. Vyberte súbor FBX exportovaný zo softvéru Blender a kliknite na Otvoriť.
  4. V okne Nový projekt kliknite na OK.
  5. Skontrolujte, či ste sieť exportovali správne – uistite sa, že sa v paneli Zoznam súprav textúr nachádza iba jedna súprava textúr.
  6. V paneli Texture set settings – na tomto paneli kliknite na + tlačidlo a pridajte kanály:
    Tlačidlo + sa nachádza vedľa nadpisu Channels. Tlačidlo otvára rozbaľovaciu ponuku, v ktorej sa zobrazujú ďalšie dostupné kanály.
    • Povinné: Ambient occlusion.
    • Voliteľné: Emissive. Tento kanál pridajte v prípade, že má váš model komponenty, ktoré budú vyžarovať svetlo.
    • Voliteľné: Opacity. Tento kanál pridajte v prípade, že má váš model komponenty, ktoré budú priehľadné.
  7. Na paneli Texture set settings kliknite na Bake Mesh Maps.
  8. Namaľujte textúry na model.

Viaceré súpravy textúr

Keď naimportujete súbor FBX do aplikácie Substance Painter, mala by k dispozícii len jedna súprava textúr:

Súpravy textúr sú uvedené na paneli Texture set list.

Ak sa zobrazuje viac ako jedna súprava textúr, pri exporte siete (mesh) z aplikácie Blender došlo k jednej z nasledujúcich chýb:

  • Sieť nebola spojená do jedného objektu.
  • K sieti bola priradená viac ako jedna textúra.

V takom prípade svoj model znova exportujte z aplikácie Blender a uistite sa, že sieť je jeden objekt a má priradenú len jednu textúru.

Export súboru glTF z aplikácie Substance Painter

  1. Kliknite na File > Export Textures.

  2. V rozbaľovacej ponuke Config vyberte glTF PBR Metal Roughness.

  3. Vyberte lokalitu, kam chcete textúry uložiť.

  4. Zvoľte si veľkosť dokumentu, čím určíte, aké veľké budú súbory textúr.

  5. Kliknite na Export.

Kompresia súborov textúr

Po exportovaní modelu by ste mali mať k dispozícii tieto súbory:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Pri použití konfigurácie glTF PBR Metal Roughness aplikácia Substance Painter exportuje súbory textúr len vo formáte PNG. Zvážte kompresiu súborov textúr a konverziu všetkých textúr, ktoré nepotrebujú alfa kanál, do formátu JPG. Tým sa zníži celková veľkosť súboru. Menšie súbory umožňujú rýchlejšie sťahovanie a plynulejšie interakcie.

Najlepšie je udržiavať veľkosť súboru do 4 MB.

Vytvorenie súboru GLB

  1. Prejdite na adresu https://glb-packer-old.glitch.me/.
  2. Súbory exportované z aplikácie Substance Painter pretiahnite na webovú stránku GLB Packer.

Do počítača sa stiahne súbor s názvom out.glb. Po dokončení sťahovania môžete súbor premenovať a nahrať ho do služby Shopify.