Vytváranie súborov GLB pomocou 3ds Max a Substance Painter

Aplikácie 3ds Max a Substance Painter môžete použiť na export súboru GLB, ktorý je možné pridať k produktu v administrátorovi Shopify. 3D modely pomáhajú zákazníkom vizualizovať produkty, čo môže zvýšiť ich dôveru a znížiť počet vrátení.

Príprava modelu na export v 3ds Max

Ak chcete pripraviť model na export, musíte sa uistiť, že ide o jednu sieť a že je na ňu použitý jeden materiál.

Kroky:

  1. Kliknite na File > Import... > Import....
  2. Vyberte súbor s modelom a kliknite na Open.
  3. V dialógovom okne OBJ Import Options začiarknite políčko Import as a single mesh.
  4. Kliknite na Import.
  5. Rozviňte model do priestoru 0–1. Uistite sa, že sa žiadne UV neprekrývajú:
    Pomocou editora Edit UVWs rozložte UV medzi 0 a 1 na osiach X a Y.
  6. Použite jeden materiál na celý model.

Export siete z 3ds Max

  1. Kliknite na File > Export > Export...
  2. Zadajte názov súboru a umiestnenie, kam chcete model exportovať.
  3. V rozbaľovacej ponuke Save as Type vyberte možnosť OBJ-Export (.OBJ).
  4. Kliknite na Save.
  5. V dialógovom okne OBJ Export Options ponechajte predvolené možnosti tak, ako sú, a kliknite na Export.

Import a príprava súboru OBJ v programe Substance Painter

  1. Vytvorte nový projekt v programe Substance Painter kliknutím na File > New.
  2. V dialógovom okne New project kliknite na Select a vyberte sieť.
  3. Vyberte súbor OBJ, ktorý ste exportovali z 3ds Max, a kliknite na Open.
  4. V okne New project kliknite na OK.
  5. Overte si, či ste sieť exportovali správne, a to kontrolou, či sa v paneli Texture set list nachádza len jedna súprava textúr.
  6. V paneli Texture set settings kliknite na tlačidlo + a pridajte kanály:
    Tlačidlo + sa nachádza vedľa nadpisu Channels. Toto tlačidlo otvára rozbaľovaciu ponuku, v ktorej sa zobrazujú ďalšie dostupné kanály.
    • Povinné: Ambient occlusion.
    • Voliteľné: Emissive. Tento kanál pridajte, ak má váš model komponenty, ktoré budú vyžarovať svetlo.
    • Voliteľné: Opacity. Tento kanál pridajte, ak má váš model komponenty, ktoré budú priehľadné.
  7. V paneli Texture set settings kliknite na Bake Mesh Maps.
  8. Namaľujte na model textúry.

Viac súprav textúr

Pri importe súboru OBJ do programu Substance Painter by mala existovať iba jedna súprava textúr:

Súpravy textúr sú uvedené v paneli Texture set list.

Ak sa zobrazuje viac ako jedna súprava textúr, pri exporte siete z 3ds Max nastala jedna z nasledujúcich chýb:

  • Sieť nebola spojená do jedného objektu.
  • Sieti bola priradená viac ako jedna textúra.

Ak je to tak, znova exportujte model zo softvéru 3ds Max a uistite sa, že sieť je jeden objekt a má priradenú iba jednu textúru.

Export súboru glTF zo softvéru Substance Painter

  1. Kliknite na Súbor > Exportovať textúry.

  2. V rozbaľovacej ponuke Config vyberte možnosť glTF PBR Metal Roughness.

  3. Vyberte umiestnenie, kam chcete uložiť textúry.

  4. Vyberte veľkosť dokumentu na určenie veľkosti súborov textúr.

  5. Kliknite na Exportovať.

Kompresia súborov textúr

Po exportovaní modelu by ste mali mať nasledujúce súbory:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Pri použití konfigurácie glTF PBR Metal Roughness exportuje Substance Painter súbory textúr iba vo formáte PNG. Zvážte kompresiu súborov textúr a konverziu textúr, ktoré nepotrebujú alfa kanál, do formátu JPG. Tým sa zmenší celková veľkosť súboru, pričom menšie súbory umožňujú rýchlejšie sťahovanie a plynulejšie interakcie.

Najlepšie je udržiavať veľkosť súboru do 4 MB.

Vytvorenie súboru GLB

  1. Prejdite na stránku https://glb-packer-old.glitch.me/.
  2. Pretiahnite súbory exportované zo softvéru Substance Painter na webovú stránku GLB Packer.

Do počítača sa stiahne súbor s názvom out.glb. Po dokončení sťahovania môžete súbor premenovať a nahrať do služby Shopify.