Criação de arquivos GLB com o Maya e o Substance Painter

Use o Maya e o Substance Painter para exportar um arquivo GLB que pode ser adicionado a um produto no admin da Shopify. Os modelos 3D ajudam os clientes a visualizar os produtos, o que pode aumentar a confiança e reduzir as devoluções.

Preparar o modelo para exportação no Maya

Para preparar o modelo para exportação, verifique se ele é uma malha única e se tem apenas um material aplicado.

Etapas:

  1. Importe o modelo para o Maya em Arquivo > Importar..., escolha o arquivo 3D e clique em Importar.
  2. Clique em Mesh > Combine para combinar a malha em um único objeto.
  3. Abra a malha do modelo no espaço UV 0-1. Verifique se nenhum UV se sobrepõe:
    Use o UV Editor para organizar os UVs entre 0 e 1 nos eixos X e Y.
  4. Aplique um material Phong ao modelo:
    1. Com o cursor do mouse sobre o modelo, clique com o botão direito e segure. Em seguida, selecione Assign New Material...
    2. Na caixa de diálogo, selecione Phong.

Exportar a malha do Maya

  1. Selecione a malha inteira e clique em Arquivo > Exportar seleção...
  2. Insira um nome para o arquivo e o local onde ele deve ser salvo.
  3. No menu suspenso Tipo de arquivo, selecione OBJexport.
  4. Clique em Exportar seleção.

Importar e preparar o arquivo OBJ no Substance Painter

  1. Crie um novo projeto no Substance Painter clicando em Arquivo > Novo.
  2. Na caixa de diálogo Novo projeto, clique em Selecionar para escolher uma malha.
  3. Selecione o arquivo OBJ que você exportou do Maya e clique em Abrir.
  4. Na janela Novo projeto, clique em OK.
  5. Verifique se você exportou a malha corretamente, conferindo se há apenas um conjunto de texturas no painel Lista de conjuntos de texturas .
  6. No painel Configurações do conjunto de texturas , clique no botão + para adicionar canais:
    O botão + fica ao lado do título Canais. O botão abre um menu suspenso que mostra os canais adicionais disponíveis.
    • Obrigatório: oclusão de ambiente.
    • Opcional: emissivo. Adicione este canal se o modelo tiver componentes que emitirão luz.
    • Opcional: opacidade. Adicione este canal se o modelo tiver componentes que serão transparentes.
  7. No painel Configurações do conjunto de texturas, clique em Bake Mesh Maps.
  8. Pinte as texturas no modelo.

Vários conjuntos de textura

Ao importar o arquivo OBJ para o Substance Painter, deve haver apenas um conjunto de texturas:

Os conjuntos de textura são listados no painel da lista de conjuntos de texturas.

Se mais de um conjunto de texturas for exibido, um dos erros a seguir ocorreu quando a malha foi exportada do Maya:

  • A malha não foi combinada em um único objeto.
  • A malha tinha mais de uma textura atribuída.

Nesse caso, exporte o modelo do Maya novamente e verifique se a malha é um único objeto com apenas uma textura atribuída.

Exportar o arquivo glTF do Substance Painter

  1. Clique em Arquivo > Exportar texturas.

  2. No menu suspenso Config, selecione glTF PBR Metal Roughness.

  3. Escolha o local onde quer salvar as texturas.

  4. Escolha o tamanho do documento para definir o tamanho dos arquivos de textura.

  5. Clique em Exportar.

Compactação de arquivos de textura

Depois de exportar o modelo, você terá os seguintes arquivos:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Ao usar a configuração glTF PBR Metal Roughness, o Substance Painter exporta os arquivos de textura somente no formato PNG. Considere compactar os arquivos de textura e converter para JPG as texturas que não precisam de um canal alfa. Isso reduz o tamanho total do arquivo, e arquivos menores permitem downloads mais rápidos e interações mais fluidas.

É recomendável manter o tamanho do arquivo em 4 MB ou menos.

Criar um arquivo GLB

  1. Acesse https://glb-packer-old.glitch.me/.
  2. Arraste e solte os arquivos que você exportou do Substance Painter na página do GLB Packer.

Um arquivo chamado out.glb será baixado no computador. Após a conclusão do download, renomeie o arquivo e faça o upload na Shopify.