GLB-bestanden aanmaken met Maya en Substance Painter

Je kunt Maya en Substance Painter gebruiken om een GLB-bestand te exporteren dat kan worden toegevoegd aan een product in het Shopify-beheercentrum. 3D-modellen kunnen klanten helpen producten te visualiseren, wat het vertrouwen kan vergroten en het aantal retouren kan verminderen.

Je model voorbereiden voor export in Maya

Om je model voor te bereiden op de export, moet je ervoor zorgen dat het één enkele mesh is en dat er één enkel materiaal op is toegepast.

Stappen:

  1. Importeer je model in Maya door naar File > Import... te gaan, je 3D-bestand te kiezen en vervolgens op Import te klikken.
  2. Klik op Mesh > Combine om je mesh tot één object te combineren.
  3. Unwrap het model in 0-1 UV-ruimte. Zorg ervoor dat er geen UV's overlappen:
    Gebruik de UV Editor om de UV's tussen 0 en 1 op de X- en Y-as te rangschikken.
  4. Pas een Phong-materiaal toe op het model:
    1. Houd de muisaanwijzer boven het model, klik met de rechtermuisknop en selecteer vervolgens Assign New Material...
    2. Selecteer Phong in het dialoogvenster.

De mesh exporteren vanuit Maya

  1. Selecteer de hele mesh en klik vervolgens op File > Export Selection...
  2. Voer een bestandsnaam in en de locatie waar het bestand moet worden opgeslagen.
  3. Selecteer OBJexport in de vervolgkeuzelijst Files of type.
  4. Klik op Export Selection.

Het OBJ-bestand importeren en voorbereiden in Substance Painter

  1. Maak een nieuw Substance Painter-project aan door op File > New te klikken.
  2. Klik in het dialoogvenster New project op Select om een mesh te kiezen.
  3. Selecteer het OBJ-bestand dat je vanuit Maya hebt geëxporteerd en klik vervolgens op Open.
  4. Klik op OK in het venster New project.
  5. Controleer of je de mesh correct hebt geëxporteerd door te controleren of er slechts één textuurset is in het paneel Texture set list .
  6. Klik in het paneel Texture set settings op de knop + om kanalen toe te voegen:
    De knop + staat naast de kop Channels. De knop opent een vervolgkeuzelijst met de extra beschikbare kanalen.
    • Vereist: Ambient occlusion.
    • Optioneel: Emissive. Voeg dit kanaal toe als je model componenten heeft die licht uitstralen.
    • Optioneel: Opacity. Voeg dit kanaal toe als je model componenten heeft die transparant zijn.
  7. Klik in het paneel Texture set settings op Bake Mesh Maps.
  8. Verf texturen op het model.

Meerdere textuursets

Wanneer je het OBJ-bestand importeert in Substance Painter, zou er maar één textuurset moeten zijn:

Textuursets staan in het paneel Textuursetlijst.

Als er meer dan één textuurset wordt weergegeven, is een van de volgende dingen misgegaan bij het exporteren van de mesh vanuit Maya:

  • De mesh is niet gecombineerd tot één object.
  • Aan de mesh was meer dan één textuur toegewezen.

Als dat het geval is, exporteer je je model opnieuw vanuit Maya en zorg je ervoor dat de mesh één object is en er maar één textuur aan is toegewezen.

Het glTF-bestand exporteren vanuit Substance Painter

  1. Klik op Bestand > Texturen exporteren.

  2. Selecteer glTF PBR Metal Roughness in de vervolgkeuzelijst Config.

  3. Kies de locatie waar je je texturen wilt opslaan.

  4. Kies een documentgrootte om te bepalen hoe groot de textuurbestanden worden.

  5. Klik op Exporteren.

Textuurbestanden comprimeren

Wanneer je het model hebt geëxporteerd, heb je de volgende bestanden:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Wanneer je de configuratie glTF PBR Metal Roughness gebruikt, exporteert Substance Painter textuurbestanden alleen in PNG-indeling. Overweeg de textuurbestanden te comprimeren en texturen die geen alfakanaal nodig hebben, te converteren naar JPG. Dit verkleint de totale bestandsgrootte en kleinere bestandsgroottes zorgen voor snellere downloads en soepelere interacties.

Je kunt je bestandsgrootte het beste op 4 MB of kleiner houden.

Een GLB-bestand aanmaken

  1. Ga naar https://glb-packer-old.glitch.me/.
  2. Sleep de bestanden die je uit Substance Painter hebt geëxporteerd naar de webpagina van GLB Packer.

Er wordt een bestand met de naam out.glb naar je computer gedownload. Nadat de download is voltooid, kun je het bestand een andere naam geven en het vervolgens uploaden naar Shopify.