GLB-bestanden aanmaken met 3ds Max en Substance Painter
Je kunt 3ds Max en Substance Painter gebruiken om een GLB-bestand te exporteren dat kan worden toegevoegd aan een product in het Shopify-beheercentrum. 3D-modellen kunnen klanten helpen producten te visualiseren, wat het vertrouwen kan vergroten en het aantal retouren kan verminderen.
Op deze pagina
Je model voorbereiden voor export in 3ds Max
Om je model voor te bereiden voor export, moet je ervoor zorgen dat het één enkele mesh is en dat er maar één materiaal op is toegepast.
Stappen:
- Klik op File > Import... > Import....
- Selecteer je modelbestand en klik op Open.
- Vink in het dialoogvenster OBJ Import Options de optie Import as a single mesh aan.
- Klik op Import.
- Unwrap het model in 0-1-ruimte. Zorg ervoor dat er geen UV's overlappen:

- Pas één materiaal toe op het hele model.
De mesh exporteren uit 3ds Max
- Klik op File > Export > Export...
- Voer een bestandsnaam in en de locatie waarnaar je het model wilt exporteren.
- Selecteer OBJ-Export (.OBJ) in de vervolgkeuzelijst Save as Type.
- Klik op Save.
- Laat in het dialoogvenster OBJ Export Options de standaardopties ongewijzigd en klik op Export.
Het OBJ-bestand importeren en voorbereiden in Substance Painter
- Maak een nieuw Substance Painter-project aan door te klikken op File > New.
- Klik in het dialoogvenster Nieuw project op Selecteren om een mesh te kiezen.
- Selecteer het OBJ-bestand dat je hebt geëxporteerd uit 3ds Max en klik vervolgens op Openen.
- Klik in het venster Nieuw project op OK.
- Controleer of je je mesh correct hebt geëxporteerd door na te gaan of er maar één textuurset in het Lijst met textuursets paneel staat.
- Als er meer dan één textuurset wordt weergegeven, raadpleeg je Meerdere textuursets.
- Klik in het Instellingen voor textuurset -paneel op de
+-knop om kanalen toe te voegen:
- Vereist: Ambient occlusion.
- Optioneel: Emissive. Voeg dit kanaal toe als je model componenten heeft die licht uitstralen.
- Optioneel: Opacity. Voeg dit kanaal toe als je model componenten heeft die transparant zijn.
- Klik in het paneel Instellingen voor textuurset op Bake Mesh Maps.
- Texturen op het model schilderen.
Meerdere textuursets
Wanneer je het OBJ-bestand in Substance Painter importeert, mag er maar één textuurset zijn:

Als je meer dan één textuurset ziet, is er bij het exporteren van de mesh uit 3ds Max een van de volgende dingen fout gegaan:
- De mesh is niet samengevoegd tot één object.
- Aan de mesh was meer dan één textuur toegewezen.
Als dat het geval is, exporteer je je model opnieuw vanuit 3ds Max en zorg je ervoor dat de mesh één object is en dat er maar één textuur aan is toegewezen.
Het glTF-bestand exporteren uit Substance Painter
Klik op Bestand > Texturen exporteren.
Selecteer glTF PBR Metal Roughness in de Config-vervolgkeuzelijst.
Kies de locatie waar je je texturen wilt opslaan.
Kies een documentgrootte om te bepalen hoe groot de textuurbestanden zullen zijn.
Klik op Exporteren.
Textuurbestanden comprimeren
Wanneer je het model hebt geëxporteerd, zou je de volgende bestanden moeten hebben:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Bij gebruik van de configuratie glTF PBR Metal Roughness exporteert Substance Painter alleen textuurbestanden in PNG-indeling. Overweeg de textuurbestanden te comprimeren en eventuele texturen die geen alfakanaal nodig hebben, te converteren naar een JPG. Dit verkleint de totale bestandsgrootte en kleinere bestandsgroottes zorgen voor snellere downloads en soepelere interacties.
Je kunt de bestandsgrootte het beste op 4 MB of kleiner houden.
Een GLB-bestand aanmaken
- Ga naar https://glb-packer-old.glitch.me/.
- Sleep de bestanden die je uit Substance Painter hebt geëxporteerd naar de webpagina van GLB Packer en zet ze daar neer.
Er wordt een bestand met de naam out.glb naar je computer gedownload. Nadat de download is voltooid, kun je de naam van het bestand wijzigen en het vervolgens uploaden naar Shopify.