Mencipta fail GLB menggunakan Maya dan Substance Painter

Anda boleh menggunakan Maya dan Substance Painter untuk mengeksport fail GLB yang boleh ditambahkan pada produk dalam pentadbir Shopify. Model 3D boleh membantu pelanggan menggambarkan produk, yang dapat meningkatkan keyakinan dan mengurangkan pemulangan.

Sediakan model anda untuk dieksport dalam Maya

Untuk menyediakan model anda bagi tujuan eksport, anda perlu memastikan model tersebut ialah satu jaringan tunggal dan mempunyai satu bahan tunggal yang digunakan padanya.

Langkah-langkah:

  1. Import model anda ke dalam Maya dengan pergi ke File > Import..., memilih fail 3D anda, dan kemudian mengklik Import.
  2. Klik Mesh > Combine untuk menggabungkan jaringan anda menjadi satu objek tunggal.
  3. Bentangkan model ke dalam ruang UV 0-1. Pastikan tiada UV yang bertindih:
    Gunakan UV Editor untuk membentangkan UV antara 0 dengan 1 pada paksi X dan Y.
  4. Gunakan bahan Phong pada model:
    1. Halakan kursor tetikus anda pada model, klik kanan dan tahan, kemudian pilih Assign New Material...
    2. Daripada dialog, pilih Phong.

Eksport jaringan dari Maya

  1. Pilih seluruh jaringan, kemudian klik File > Export Selection...
  2. Masukkan nama fail dan lokasi tempat fail tersebut patut disimpan.
  3. Daripada menu juntai bawah Files of type, pilih OBJexport.
  4. Klik Export Selection.

Import dan sediakan fail OBJ dalam Substance Painter

  1. Cipta projek Substance Painter baharu dengan mengklik File > New.
  2. Dalam dialog New project, klik Select untuk memilih jaringan.
  3. Pilih fail OBJ yang telah anda eksport dari Maya, kemudian klik Open.
  4. Dalam tetingkap New project, klik OK.
  5. Sahkan bahawa anda telah mengeksport jaringan anda dengan betul dengan menyemak sama ada terdapat hanya satu set tekstur dalam panel Texture set list .
  6. Dalam panel Texture set settings , klik butang + untuk menambah saluran:
    Butang + berada di sebelah tajuk Channels. Butang membuka menu juntai bawah yang menunjukkan saluran tambahan yang tersedia.
    • Wajib: Ambient occlusion.
    • Pilihan: Emissive. Tambah saluran ini jika model anda mempunyai komponen yang akan memancarkan cahaya.
    • Pilihan: Opacity. Tambah saluran ini jika model anda mempunyai komponen yang akan menjadi lut sinar.
  7. Dalam panel Texture set settings, klik Bake Mesh Maps.
  8. Lukiskan tekstur pada model.

Set tekstur berbilang

Apabila anda mengimport fail OBJ ke dalam Substance Painter, hanya sepatutnya terdapat satu set tekstur:

Set tekstur disenaraikan dalam panel Texture set list.

Jika lebih daripada satu set tekstur dipaparkan, salah satu perkara yang berikut adalah tidak betul semasa jaringan dieksport dari Maya:

  • Jaringan tidak digabungkan menjadi objek tunggal.
  • Terdapat lebih daripada satu tekstur yang diperuntukkan pada jaringan.

Jika itu berlaku, eksport semula model anda dari Maya dan pastikan jaringan itu ialah objek tunggal dan hanya mempunyai satu tekstur tunggal yang diperuntukkan padanya.

Eksport fail glTF dari Substance Painter

  1. Klik File > Export Textures.

  2. Daripada menu juntai bawah Config, pilih glTF PBR Metal Roughness.

  3. Pilih lokasi tempat anda ingin menyimpan tekstur anda.

  4. Pilih saiz dokumen untuk menentukan saiz fail tekstur tersebut kelak.

  5. Klik Export.

Memampatkan fail tekstur

Apabila anda telah mengeksport model, anda sepatutnya mempunyai fail yang berikut:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Apabila menggunakan konfigurasi glTF PBR Metal Roughness, Substance Painter mengeksport fail tekstur hanya dalam format PNG. Pertimbangkan untuk memampatkan fail tekstur dan menukar apa-apa tekstur yang tidak memerlukan saluran alfa kepada JPG. Ini akan mengurangkan jumlah saiz fail dan saiz fail yang lebih kecil membolehkan kelajuan muat turun yang lebih pantas dan interaksi yang lebih lancar.

Sebaik-baiknya, kekalkan saiz fail anda pada 4 MB atau lebih kecil.

Cipta fail GLB

  1. Lawati https://glb-packer-old.glitch.me/.
  2. Seret dan lepas fail yang anda eksport dari Substance Painter ke halaman web GLB Packer.

Fail yang dipanggil out.glb akan dimuat turun ke komputer anda. Selepas muat turun selesai, anda boleh menamakan semula fail dan kemudian memuat naiknya ke Shopify.