Maya と Substance Painter を使用して GLB ファイルを作成する

Maya と Substance Painter を使用して、Shopify の管理画面で商品に追加できる GLB ファイルをエクスポートできます。3Dモデルは、お客様が商品を視覚化するのに役立ち、信頼感を高めて返品を減らすことにつながります。

Maya でモデルをエクスポート用に準備する

モデルをエクスポート用に準備するには、モデルが単一のメッシュであり、単一のマテリアルが適用されていることを確認する必要があります。

手順:

  1. [ファイル] > [インポート...] に移動して 3D ファイルを選択し、[インポート] をクリックして、モデルを Maya にインポートします。
  2. [メッシュ] > [結合] をクリックして、メッシュを単一のオブジェクトに結合します。
  3. モデルを 0-1 の UV 空間にアンラップします。UV が重ならないようにしてください。
    UVエディタを使用して、X軸とY軸の0から1の間にUVをレイアウトします。
  4. Phong マテリアルをモデルに適用します。
    1. モデルにマウスカーソルを合わせて右クリックしたまま、[新しいマテリアルの割り当て...] を選択します。
    2. ダイアログから [Phong] を選択します。

Maya からメッシュをエクスポートする

  1. メッシュ全体を選択し、[ファイル] > [選択項目のエクスポート...] をクリックします。
  2. ファイル名とファイルの保存場所を入力します。
  3. [ファイルの種類] ドロップダウンメニューから [OBJexport] を選択します。
  4. [選択項目のエクスポート] をクリックします。

Substance Painter で OBJ ファイルをインポートして準備する

  1. [ファイル] > [新規] をクリックして、新しい Substance Painter プロジェクトを作成します。
  2. [新規プロジェクト] ダイアログで [選択] をクリックしてメッシュを選択します。
  3. Maya からエクスポートした OBJ ファイルを選択し、[開く] をクリックします。
  4. [新規プロジェクト] ウィンドウで、[OK] をクリックします。
  5. メッシュが正しくエクスポートされたことを確認するには、テクスチャセットが 1 つしかないことを [ テクスチャセットリスト パネル。
  6. テクスチャセット設定 」パネルで、「 + 」ボタンをクリックしてチャネルを追加します。
    [チャネル] の見出しの横にある [+] ボタン。ボタンをクリックすると、利用可能な追加チャネルを示すドロップダウンメニューが開きます。
    • 必須:アンビエントオクルージョン。
    • 任意:エミッシブ。モデルに発光するコンポーネントがある場合は、このチャネルを追加します。
    • 任意:不透明度。モデルに透明なコンポーネントがある場合は、このチャネルを追加します。
  7. [テクスチャセット設定] パネルで、[ベイクメッシュマップ] をクリックします。
  8. モデルにテクスチャをペイントします。

複数のテクスチャセット

OBJ ファイルを Substance Painter にインポートする際に、テクスチャセットは 1 つだけである必要があります。

テクスチャセットリストパネルに表示されるテクスチャセット。

複数のテクスチャセットが表示される場合、Maya からメッシュをエクスポートした際に、次のいずれかに誤りがありました。

  • メッシュが単一のオブジェクトに結合されていませんでした。
  • メッシュに複数のテクスチャが割り当てられていました。

その場合は、Maya からモデルを再度エクスポートし、メッシュが単一のオブジェクトであること、また、割り当てられているテクスチャが 1 つだけであることを確認してください。

Substance Painter から glTF ファイルをエクスポートする

  1. 「File」>「Export Textures」の順にクリックします。

  2. 「Config」ドロップダウンメニューから、「glTF PBR Metal Roughness」を選択します。

  3. テクスチャを保存するロケーションを選択します。

  4. ドキュメントサイズを選択して、テクスチャファイルのサイズを決定します。

  5. [エクスポート] をクリックします。

テクスチャファイルを圧縮する

モデルをエクスポートすると、以下のファイルが生成されます。

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

「glTF PBR Metal Roughness」設定を使用すると、Substance Painter はテクスチャファイルを PNG 形式でのみエクスポートします。テクスチャファイルを圧縮し、アルファチャンネルを必要としないテクスチャを JPG に変換することを検討してください。これにより、合計ファイルサイズが削減されます。ファイルサイズが小さいと、ダウンロード速度が向上し、インタラクションがスムーズになります。

ファイルサイズは 4 MB 以下にすることをおすすめします。

GLB ファイルを作成する

  1. https://glb-packer-old.glitch.me/ にアクセスします。
  2. Substance Painter からエクスポートしたファイルを、GLB Packer のウェブページにドラッグ&ドロップします。

out.glb という名前のファイルがコンピューターにダウンロードされます。ダウンロードが完了したら、ファイル名を変更して Shopify にアップロードできます。