Blender と Substance Painter を使用して GLB ファイルを作成する

バージョン 2.8 以降の Blender では、Shopify 管理画面で商品に追加できる GLB ファイルをエクスポートできます。詳しくは、Blender のマニュアルをご覧ください。

Blender の旧バージョンでは、Blender と Substance Painter を組み合わせて GLB ファイルをエクスポートできます。

Blender でモデルをエクスポートするための準備を行う

モデルをエクスポート用に準備するには、モデルが単一のメッシュであり、単一のテクスチャが適用されていることを確認する必要があります。

手順:

  1. File」 > 「Import」の順にクリックし、モデルに適したファイル形式を選択します。
  2. モデルファイルを選択し、「Import」をクリックします。
  3. SHIFT キーを押しながらシーン内の各オブジェクトを右クリックし、Ctrl + J キーを押して、それらを 1 つのメッシュに統合します。
  4. モデルを 0-1 UV 空間にアンラップします。UV が重ならないようにしてください。
    UV/Image Editorで、すべてのUVがグリッド上に配置されていることを確認します。
  5. [プロパティ] エディタで、マテリアルアイコンをクリックします。
  6. + 」ボタンをクリックして、新しいマテリアルスロットを追加します。
    「マテリアルスロットを追加」ボタンは、「マテリアル」ペインの上部付近にあります。
  7. [新規] をクリックします。

Blender からメッシュをエクスポートする

  1. [ファイル] > [エクスポート] > [FBX (.fbx)] の順にクリックします。
  2. ファイルをエクスポートする先のパスを入力します。
  3. 必ず以下のエクスポート設定を使用してください。
    バージョン: FBX 7.4 binary、スケール: 1.0、スケーリングを適用: All Local、前方: -Z Forward、上: Y Up、パスモード: Auto、バッチモード: Off。
  4. [FBXをエクスポート] をクリックします。

Substance Painter で FBX ファイルをインポートして準備する

  1. [ファイル] > [新規] の順にクリックして、新しい Substance Painter プロジェクトを作成します。
  2. [新規プロジェクト] ダイアログで [選択] をクリックし、メッシュを選択します。
  3. Blender からエクスポートした FBX ファイルを選択し、[開く] をクリックします。
  4. [新規プロジェクト] ウィンドウで [OK] をクリックします。
  5. メッシュが正しくエクスポートされたか検証するには、「 Texture set list 」パネルにテクスチャセットが 1 つだけ表示されていることを確認します。
  6. テクスチャセット設定 」パネルで、 + ボタンをクリックしてチャネルを追加します。
    [+] ボタンは [チャネル] の見出しの横にあります。ボタンでドロップダウンメニューが開き、利用可能な追加のチャネルが表示されます。
    • 必須:アンビエントオクルージョン。
    • 任意:エミッシブ。モデルに発光するコンポーネントがある場合は、このチャネルを追加します。
    • 任意:オパシティ。モデルに透明なコンポーネントがある場合は、このチャネルを追加します。
  7. [テクスチャセット設定] パネルで、[メッシュマップをベイク処理] をクリックします。
  8. モデルにテクスチャをペイントします。

複数のテクスチャセット

FBX ファイルを Substance Painter にインポートする際に、テクスチャセットが 1 つだけ表示される必要があります。

テクスチャセットは、「Texture set list」パネルに一覧表示されます。

複数のテクスチャセットが表示される場合、Blender からメッシュをエクスポートした際に、以下のいずれかに誤りがあったことを意味します。

  • メッシュが単一のオブジェクトに結合されていませんでした。
  • メッシュに複数のテクスチャが割り当てられていました。

その場合は、Blender からモデルを再度エクスポートし、メッシュが単一のオブジェクトであり、割り当てられているテクスチャが 1 つだけであることを確認してください。

Substance Painter から glTF ファイルをエクスポートする

  1. [ファイル] > [テクスチャをエクスポート] の順にクリックします。

  2. Config ドロップダウンメニューから、glTF PBR Metal Roughness を選択します。

  3. テクスチャを保存するロケーションを選択します。

  4. ドキュメントサイズを選択して、テクスチャファイルのサイズを決定します。

  5. [エクスポート] をクリックします。

テクスチャファイルの圧縮

モデルをエクスポートすると、以下のファイルが作成されます。

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

glTF PBR Metal Roughness 設定を使用する場合、Substance Painter は PNG 形式でのみテクスチャファイルをエクスポートします。テクスチャファイルを圧縮し、アルファチャネルを必要としないテクスチャは JPG に変換することを検討してください。これにより、ファイルサイズ全体が縮小され、ファイルサイズが小さいほどダウンロード速度が向上し、インタラクションがスムーズになります。

ファイルサイズは 4 MB 以下にすることをおすすめします。

GLB ファイルを作成する

  1. https://glb-packer-old.glitch.me/ にアクセスします。
  2. Substance Painter からエクスポートしたファイルを GLB Packer のウェブページにドラッグ&ドロップします。

out.glb という名前のファイルがコンピューターにダウンロードされます。ダウンロードが完了したら、ファイル名を変更して Shopify にアップロードできます。