3ds Max と Substance Painter を使用した GLB ファイルの作成
3ds Max と Substance Painter を使用して GLB ファイルをエクスポートし、管理画面で商品に追加できます。3D モデルは、お客様が商品を視覚化するのに役立ち、信頼性を高めて返品を減らすことができます。
このページの内容
3ds Max でエクスポート用にモデルを準備する
モデルをエクスポート用に準備するには、モデルが単一のメッシュであり、単一のマテリアルが適用されていることを確認する必要があります。
手順:
- [ファイル] > [インポート...] > [インポート...] の順にクリックします。
- モデルファイルを選択し、[開く] をクリックします。
- [OBJインポートオプション] ダイアログで、[単一メッシュとしてインポート] にチェックを入れます。
- [インポート] をクリックします。
- モデルを 0-1 空間にアンラップします。UV が重ならないようにしてください。
![[UVを編集] エディタを使用して、X軸とY軸で0と1の間にUVをレイアウトします。](https://cdn.shopify.com/shopifycloud/help-center/partners/3d-warehouse/3ds-max-uvs.png)
- モデル全体に単一のマテリアルを適用します。
3ds Max からメッシュをエクスポートする
- [ファイル] > [エクスポート] > [エクスポート...] の順にクリックします。
- ファイル名とモデルをエクスポートする場所を入力します。
- [ファイルの種類] ドロップダウンメニューから、[OBJ-Export (.OBJ)] を選択します。
- [保存] をクリックします。
- [OBJエクスポートオプション] ダイアログで、デフォルトのオプションをそのままにして [エクスポート] をクリックします。
Substance Painter で OBJ ファイルをインポートして準備する
- [ファイル] > [新規] の順にクリックして、新しい Substance Painter プロジェクトを作成します。
- 「New project」ダイアログで「Select」をクリックし、メッシュを選択します。
- 3ds Max からエクスポートした OBJ ファイルを選択し、「Open」をクリックします。
- 「New project」ウィンドウで、「OK」をクリックします。
- 「 Texture set list 」パネルにテクスチャセットが1つしかないことを確認し、メッシュが正しくエクスポートされていることを確かめます。
- 複数のテクスチャセットが表示される場合は、「複数のテクスチャセット」を参照してください。
- 「 Texture set settings 」パネルで、
+ボタンをクリックしてチャネルを追加します。![[チャネル] の見出しの横に [+] ボタンがあります。このボタンをクリックするとドロップダウンメニューが開き、利用可能な追加のチャネルが表示されます。](https://cdn.shopify.com/shopifycloud/help-center/partners/3d-warehouse/add-texture-channels-sublime-painter.png)
- 必須:アンビエントオクルージョン。
- オプション:エミッシブ。モデルに発光するコンポーネントがある場合は、このチャネルを追加します。
- オプション:不透明度。モデルに透明なコンポーネントがある場合は、このチャネルを追加します。
- 「Texture set settings」パネルで、「Bake Mesh Maps」をクリックします。
- モデルにテクスチャをペイントします。
複数のテクスチャセット
Substance Painter に OBJ ファイルをインポートする際、テクスチャセットは 1 つだけである必要があります。
![テクスチャセットは、[テクスチャセットリスト] パネルに一覧表示されます。](https://cdn.shopify.com/shopifycloud/help-center/partners/3d-warehouse/texture-set-list.png)
複数のテクスチャセットが表示される場合、3ds Max からメッシュをエクスポートする際に、以下のいずれかが間違っていたことになります。
- メッシュが1つのオブジェクトに結合されていません。
- メッシュに複数のテクスチャが割り当てられています。
その場合は、3ds Max からモデルを再度エクスポートし、メッシュが単一のオブジェクトであり、割り当てられているテクスチャが 1 つだけであることを確認してください。
Substance Painter から glTF ファイルをエクスポートする
「File」 > 「Export Textures」の順にクリックします。
「Config」ドロップダウンメニューから、「glTF PBR Metal Roughness」を選択します。
テクスチャを保存するロケーションを選択します。
ドキュメントサイズを選択して、テクスチャファイルのサイズを決定します。
「Export」をクリックします。
テクスチャファイルを圧縮する
モデルをエクスポートすると、以下のファイルが生成されます。
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
「glTF PBR Metal Roughness」設定を使用する場合、Substance PainterはテクスチャファイルをPNG形式でのみエクスポートします。テクスチャファイルを圧縮し、アルファチャネルを必要としないテクスチャはJPGに変換することを検討してください。これにより合計ファイルサイズが削減され、ファイルサイズが小さいほどダウンロード速度が速くなり、インタラクションがスムーズになります。
ファイルサイズは 4 MB 以下にすることをおすすめします。
GLB ファイルを作成する
- https://glb-packer-old.glitch.me/ にアクセスします。
- Substance Painter からエクスポートしたファイルを GLB Packer のウェブページにドラッグ&ドロップします。
out.glb という名前のファイルがコンピューターにダウンロードされます。ダウンロードが完了したら、ファイルの名前を変更して Shopify にアップロードできます。