Creazione di file GLB con Maya e Substance Painter

Puoi usare Maya e Substance Painter per esportare un file GLB da aggiungere a un prodotto nel pannello di controllo Shopify. I modelli 3D possono aiutare i clienti a visualizzare i prodotti, il che può aumentare la fiducia e ridurre i resi.

Prepara il modello per l'esportazione in Maya

Per preparare il modello per l'esportazione, devi assicurarti che sia una singola mesh e che abbia un unico materiale applicato.

Passaggi:

  1. Importa il modello in Maya andando su File > Importa..., scegliendo il file 3D e quindi cliccando su Importa.
  2. Clicca su Mesh > Combina per unire la mesh in un unico oggetto.
  3. Esegui l’unwrap del modello nello spazio UV 0-1. Assicurati che nessun UV si sovrapponga:
    Usa l'editor UV per disporre gli UV tra 0 e 1 sugli assi X e Y.
  4. Applica un materiale Phong al modello:
    1. Con il cursore del mouse sul modello, fai clic con il pulsante destro del mouse e tieni premuto, quindi seleziona Assegna nuovo materiale...
    2. Dalla finestra di dialogo, seleziona Phong.

Esporta la mesh da Maya

  1. Seleziona l'intera mesh, quindi clicca su File > Esporta selezione...
  2. Inserisci un nome per il file e la posizione in cui salvarlo.
  3. Dal menu a discesa Tipo di file, seleziona OBJexport.
  4. Clicca su Esporta selezione.

Importa e prepara il file OBJ in Substance Painter

  1. Crea un nuovo progetto di Substance Painter cliccando su File > Nuovo.
  2. Nella finestra di dialogo Nuovo progetto, clicca su Seleziona per scegliere una mesh.
  3. Seleziona il file OBJ che hai esportato da Maya, quindi clicca su Apri.
  4. Nella finestra Nuovo progetto, clicca su OK.
  5. Verifica di aver esportato correttamente la mesh controllando che nel pannello Elenco set di texture sia presente un solo set di texture.
  6. Nel pannello Impostazioni set di texture , clicca sul pulsante + per aggiungere canali:
    Il pulsante + si trova accanto all'intestazione Canali. Il pulsante apre un menu a discesa che mostra i canali aggiuntivi disponibili.
    • Obbligatorio: occlusione ambientale.
    • Facoltativo: emissivo. Aggiungi questo canale se il modello ha componenti che emetteranno luce.
    • Facoltativo: opacità. Aggiungi questo canale se il modello ha componenti che saranno trasparenti.
  7. Nel pannello Impostazioni set di texture, clicca su Bake Mesh Maps.
  8. Dipingi le texture sul modello.

Più set di texture

Quando importi il file OBJ in Substance Painter, dovrebbe esserci un solo set di texture:

I set di texture sono elencati nel pannello dell'elenco dei set di texture.

Se viene visualizzato più di un set di texture, si è verificato uno dei seguenti errori durante l'esportazione della mesh da Maya:

  • La mesh non è stata combinata in un unico oggetto.
  • Alla mesh era assegnata più di una texture.

In tal caso, esporta di nuovo il modello da Maya e assicurati che la mesh sia un singolo oggetto e che abbia una sola texture assegnata.

Esporta il file glTF da Substance Painter

  1. Clicca su File > Esporta texture.

  2. Dal menu a discesa Config, seleziona glTF PBR Metal Roughness.

  3. Scegli la posizione in cui desideri salvare le texture.

  4. Scegli una dimensione del documento per determinare la grandezza dei file di texture.

  5. Clicca su Esporta.

Compressione dei file di texture

Dopo aver esportato il modello, dovresti avere i seguenti file:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Quando si utilizza la configurazione glTF PBR Metal Roughness, Substance Painter esporta i file di texture solo in formato PNG. Valuta la possibilità di comprimere i file di texture e di convertire in JPG le texture che non necessitano di un canale alfa. In questo modo si riducono le dimensioni totali del file e file di dimensioni inferiori consentono velocità di download più rapide e interazioni più fluide.

È preferibile mantenere le dimensioni del file a 4 MB o meno.

Crea un file GLB

  1. Visita https://glb-packer-old.glitch.me/.
  2. Trascina e rilascia i file che hai esportato da Substance Painter sulla pagina web di GLB Packer.

Un file denominato out.glb verrà scaricato sul tuo computer. Una volta completato il download, puoi rinominare il file e caricarlo su Shopify.