Membuat file GLB menggunakan Maya dan Substance Painter

Anda dapat menggunakan Maya dan Substance Painter untuk mengekspor file GLB yang dapat ditambahkan ke produk di admin Shopify. Model 3D dapat membantu pelanggan memvisualisasikan produk, yang dapat meningkatkan kepercayaan dan mengurangi pengembalian.

Siapkan model Anda untuk diekspor di Maya

Untuk menyiapkan model Anda untuk diekspor, pastikan model tersebut merupakan satu mesh dan hanya memiliki satu bahan yang diterapkan.

Langkah-langkah:

  1. Impor model Anda ke Maya dengan membuka File > Import..., memilih file 3D Anda, lalu mengeklik Import.
  2. Klik Mesh > Combine untuk menggabungkan mesh Anda menjadi satu objek.
  3. Bentangkan model ke dalam ruang UV 0-1. Pastikan tidak ada UV yang tumpang tindih:
    Gunakan Editor UV untuk menata UV di antara 0 dan 1 pada sumbu X dan Y.
  4. Terapkan bahan Phong ke model:
    1. Dengan kursor mouse di atas model, klik kanan dan tahan, lalu pilih Assign New Material...
    2. Dari dialog, pilih Phong.

Ekspor mesh dari Maya

  1. Pilih seluruh mesh, lalu klik File > Export Selection...
  2. Masukkan nama file dan lokasi tempat file akan disimpan.
  3. Dari menu tarik-turun Files of type, pilih OBJexport.
  4. Klik Export Selection.

Impor dan siapkan file OBJ di Substance Painter

  1. Buat proyek Substance Painter baru dengan mengeklik File > New.
  2. Di dialog New project, klik Select untuk memilih mesh.
  3. Pilih file OBJ yang Anda ekspor dari Maya, lalu klik Open.
  4. Di jendela New project, klik OK.
  5. Verifikasi bahwa Anda mengekspor mesh dengan benar dengan memeriksa bahwa hanya ada satu set tekstur di Texture set list panel.
  6. Di Pengaturan set tekstur panel, klik + tombol untuk menambahkan saluran:
    Tombol + berada di samping judul Saluran. Tombol tersebut membuka menu tarik-turun yang menampilkan saluran tambahan yang tersedia.
    • Wajib: Ambient occlusion.
    • Opsional: Emissive. Tambahkan saluran ini jika model Anda memiliki komponen yang akan memancarkan cahaya.
    • Opsional: Opacity. Tambahkan saluran ini jika model Anda memiliki komponen yang akan menjadi transparan.
  7. Di panel Pengaturan set tekstur, klik Bake Mesh Maps.
  8. Lukis tekstur pada model.

Beberapa set tekstur

Saat Anda mengimpor file OBJ ke Substance Painter, seharusnya hanya ada satu set tekstur:

Set tekstur dicantumkan di panel daftar set Tekstur.

Jika lebih dari satu set tekstur ditampilkan, artinya terjadi salah satu kesalahan berikut saat mesh diekspor dari Maya:

  • Mesh tidak digabungkan menjadi satu objek.
  • Mesh memiliki lebih dari satu tekstur yang ditetapkan padanya.

Jika demikian, ekspor model Anda dari Maya lagi dan pastikan mesh adalah objek tunggal dan hanya memiliki satu tekstur yang ditetapkan padanya.

Ekspor file glTF dari Substance Painter

  1. Klik File > Export Textures.

  2. Dari menu tarik-turun Config, pilih glTF PBR Metal Roughness.

  3. Pilih lokasi tempat Anda ingin menyimpan tekstur.

  4. Pilih ukuran dokumen untuk menentukan besarnya file tekstur.

  5. Klik Ekspor.

Mengompres file tekstur

Setelah mengekspor model, Anda akan memiliki file-file berikut:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Saat menggunakan konfigurasi glTF PBR Metal Roughness, Substance Painter mengekspor file tekstur hanya dalam format PNG. Pertimbangkan untuk mengompres file tekstur dan mengonversi tekstur apa pun yang tidak memerlukan saluran alfa ke JPG. Ini mengurangi ukuran file total, dan ukuran file yang lebih kecil memungkinkan kecepatan unduh yang lebih cepat dan interaksi yang lebih lancar.

Sebaiknya pertahankan ukuran file Anda 4 MB atau lebih kecil.

Buat file GLB

  1. Kunjungi https://glb-packer-old.glitch.me/.
  2. Seret dan lepaskan file yang Anda ekspor dari Substance Painter ke halaman web GLB Packer.

File bernama out.glb akan diunduh ke komputer Anda. Setelah unduhan selesai, Anda dapat mengganti nama file, lalu mengunggahnya ke Shopify.