GLB-fájlok létrehozása a Maya és a Substance Painter használatával

A Maya és a Substance Painter használatával exportálhat egy GLB-fájlt, amelyet hozzáadhat egy termékhez a Shopify adminisztrációs felületén. A 3D-s modellek segítenek a vásárlóknak a termékek vizualizálásában, ami növelheti a bizalmat és csökkentheti a visszaküldések számát.

A modell előkészítése exportálásra a Mayában

A modell exportálásra való előkészítéséhez győződjön meg arról, hogy egyetlen meshből áll, és egyetlen anyag van ráalkalmazva.

Lépések:

  1. Importálja a modelljét a Mayába a „File” > „Import...” (Fájl > Importálás...) menüpontra lépve, válassza ki a 3D-s fájlt, majd kattintson az „Import” (Importálás) gombra.
  2. Kattintson a „Mesh” > „Combine” (Kombinálás) lehetőségre, hogy a mesht egyetlen objektummá egyesítse.
  3. Csomagolja ki a modellt a 0-1 UV-térbe. Győződjön meg arról, hogy az UV-k nem fedik át egymást:
    Használja az UV-szerkesztőt az UV-k elrendezéséhez 0 és 1 között az X és Y tengelyen.
  4. Alkalmazzon egy Phong anyagot a modellre:
    1. Tartsa a modell fölött az egérmutatót, kattintson a jobb gombbal és tartsa lenyomva, majd válassza a „Assign New Material...” (Új anyag hozzárendelése...) lehetőséget.
    2. A párbeszédpanelen válassza a „Phong” lehetőséget.

A mesh exportálása a Mayából

  1. Válassza ki a teljes mesht, majd kattintson a „File” > „Export Selection...” (Fájl > Kijelölés exportálása...) menüpontra.
  2. Adja meg a fájl nevét és a mentési helyét.
  3. A „Files of type” (Fájltípus) legördülő menüből válassza az „OBJexport” lehetőséget.
  4. Kattintson az „Export Selection” (Kijelölés exportálása) gombra.

Az OBJ-fájl importálása és előkészítése a Substance Painterben

  1. Hozzon létre egy új Substance Painter-projektet a „File” > „New” (Fájl > Új) menüpontra kattintva.
  2. Az „New project” (Új projekt) párbeszédpanelen kattintson a „Select” (Kiválasztás) gombra a mesh kiválasztásához.
  3. Válassza ki a Mayából exportált OBJ-fájlt, majd kattintson az „Open” (Megnyitás) gombra.
  4. Az „New project” (Új projekt) ablakban kattintson az „OK” gombra.
  5. Ellenőrizze, hogy helyesen exportálta-e a mesht. Ehhez vizsgálja meg, hogy csak egy textúrakészlet van-e a „Texture set list” (Textúrakészlet-lista) panelen.
  6. A „Texture set settings” (Textúrakészlet beállításai) panelen kattintson a „+” gombra a csatornák hozzáadásához:
    A + gomb a Csatornák fejléc mellett található. A gomb egy legördülő menüt nyit meg, amely a rendelkezésre álló további csatornákat mutatja.
    • Kötelező: Környezeti fényelnyelés (Ambient occlusion).
    • Opcionális: Emisszív. Adja hozzá ezt a csatornát, ha a modellnek vannak fényt kibocsátó komponensei.
    • Opcionális: Átlátszóság (Opacity). Adja hozzá ezt a csatornát, ha a modellnek vannak átlátszó komponensei.
  7. A „Texture set settings” (Textúrakészlet beállításai) panelen kattintson a „Bake Mesh Maps” (Mesh-térképek „sütése”) gombra.
  8. Fessen textúrákat a modellre.

Több textúrakészlet

Amikor importálja az OBJ-fájlt a Substance Painterbe, csak egy textúrakészletnek szabad lennie:

A textúrakészletek a Textúra készlet lista panelen láthatók.

Ha egynél több textúrakészlet jelenik meg, akkor a háló (mesh) Maya-ból való exportálásakor az alábbi hibák egyike történt:

  • A háló nem lett egyetlen objektummá egyesítve.
  • A hálóhoz egynél több textúra volt hozzárendelve.

Ebben az esetben exportálja újra a modellt a Maya-ból, és győződjön meg róla, hogy a háló egyetlen objektum, és csak egyetlen textúra van hozzárendelve.

A glTF-fájl exportálása a Substance Painterből

  1. Kattintson a Fájl > Textúrák exportálása menüpontra.

  2. A Konfiguráció legördülő menüből válassza ki a glTF PBR Metal Roughness lehetőséget.

  3. Válassza ki a helyet, ahová menteni szeretné a textúrákat.

  4. Válasszon egy dokumentumméretet a textúrafájlok méretének meghatározásához.

  5. Kattintson az Exportálás gombra.

A textúrafájlok tömörítése

A modell exportálása után a következő fájlokkal kell rendelkeznie:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

A glTF PBR Metal Roughness konfiguráció használatakor a Substance Painter a textúrafájlokat csak PNG formátumban exportálja. Fontolja meg a textúrafájlok tömörítését és azoknak a textúráknak a JPG formátumra konvertálását, amelyek nem igényelnek alfa csatornát. Ez csökkenti a teljes fájlméretet, a kisebb fájlméretek pedig gyorsabb letöltési sebességet és zökkenőmentesebb interakciókat tesznek lehetővé.

A legjobb, ha a fájl mérete legfeljebb 4 MB.

GLB-fájl létrehozása

  1. Látogasson el a(z) https://glb-packer-old.glitch.me/ oldalra.
  2. Húzza a Substance Painterből exportált fájlokat a GLB Packer weboldalára.

Egy out.glb nevű fájl fog letöltődni a számítógépére. A letöltés befejezése után átnevezheti a fájlt, majd feltöltheti a Shopifyba.