GLB-fájlok létrehozása a Blender és a Substance Painter használatával

A 2.8-as verziótól kezdve a Blender képes GLB-fájlokat exportálni, amelyek hozzáadhatók egy termékhez a Shopify adminisztrációs felületén. További információkért látogasson el a Blender kézikönyvébe.

A Blender régebbi verzióihoz a Blender és a Substance Painter kombinálásával exportálhat GLB-fájlt.

A modell előkészítése exportálásra a Blenderben

A modell exportálásra való előkészítéséhez győződjön meg arról, hogy az egyetlen hálóból áll, és csak egy textúra van rá alkalmazva.

Lépések:

  1. Kattintson a Fájl > Importálás lehetőségre, majd válassza ki a modelljének megfelelő fájlformátumot.
  2. Válassza ki a modellfájlt, majd kattintson az Importálás gombra.
  3. Miközben lenyomva tartja a SHIFT billentyűt, kattintson jobb gombbal a jelenet minden objektumára, majd a Ctrl + J billentyűkombinációval egyesítse őket egyetlen hálóvá.
  4. Hajtsa végre a modell UV-leterítését a 0-1 UV-térbe. Győződjön meg arról, hogy az UV-k nem fedik egymást:
    A UV/Image Editorben győződjön meg róla, hogy az összes UV a rácson van elrendezve.
  5. A Properties szerkesztőben kattintson az anyagok ikonra.
  6. Kattintson a + gombra egy új anyaghely hozzáadásához:
    Az „Add a material slot” gomb a „Material” panel tetejének közelében található.
  7. Kattintson a New gombra.

A mesh exportálása a Blenderből

  1. Kattintson a File > Export > FBX (.fbx) menüpontra.
  2. Adja meg az elérési utat, ahová exportálni szeretné a fájlt.
  3. Győződjön meg róla, hogy a következő exportálási beállításokat használja:
    Version: FBX 7.4 binary. Scale: 1,0. Apply Scalings: All Local. Forward: -Z Forward. Up: Y Up. Path Mode: Auto. Batch Mode: Off.
  4. Kattintson az Export FBX gombra.

Az FBX-fájl importálása és előkészítése a Substance Painterben

  1. Hozzon létre egy új Substance Painter-projektet a File > New menüpontra kattintva.
  2. Az New project párbeszédpanelen kattintson a Select gombra egy mesh kiválasztásához.
  3. Válassza ki a Blenderből exportált FBX-fájlt, majd kattintson az Open gombra.
  4. Az New project ablakban kattintson az OK gombra.
  5. Ellenőrizze, hogy helyesen exportálta-e a mesht. Ehhez nézze meg, hogy csak egy textúrakészlet van-e a Texture set list panelen.
  6. A Texture set settings panelen kattintson a + gombra csatornák hozzáadásához:
    A + gomb a Csatornák fejléc mellett található. A gomb egy legördülő menüt nyit meg, amely megjeleníti az elérhető további csatornákat.
    • Kötelező: Ambient occlusion.
    • Választható: Emissive. Adja hozzá ezt a csatornát, ha a modellnek vannak fényt kibocsátó összetevői.
    • Választható: Opacity. Adja hozzá ezt a csatornát, ha a modellnek vannak átlátszó összetevői.
  7. A Texture set settings panelen kattintson a Bake Mesh Maps elemre.
  8. Fessen textúrákat a modellre.

Több textúrakészlet

Amikor importálja az FBX-fájlt a Substance Painterbe, csak egy textúrakészletnek szabad megjelennie:

A textúrakészletek a Texture set list panelen vannak felsorolva.

Ha egynél több textúrakészlet jelenik meg, akkor a következők egyike hibás volt a mesh Blenderből történő exportálásakor:

  • A mesh nem lett egyetlen objektumba egyesítve.
  • A meshhez egynél több textúra volt hozzárendelve.

Ha ez a helyzet, exportálja újra a modellt a Blenderből, és győződjön meg róla, hogy a mesh egyetlen objektum, és csak egy textúra van hozzárendelve.

A glTF fájl exportálása a Substance Painterből

  1. Kattintson a File > Export Textures menüpontra.

  2. A Config legördülő menüből válassza a glTF PBR Metal Roughness lehetőséget.

  3. Válassza ki a helyet, ahová menteni szeretné a textúrákat.

  4. Válasszon egy dokumentumméretet a textúrafájlok méretének meghatározásához.

  5. Kattintson az Export gombra.

Textúrafájlok tömörítése

A modell exportálása után a következő fájlokkal kell rendelkeznie:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

A glTF PBR Metal Roughness konfiguráció használatakor a Substance Painter a textúrafájlokat csak PNG formátumban exportálja. Fontolja meg a textúrafájlok tömörítését, és konvertálja JPG formátumba azokat a textúrákat, amelyeknek nincs szükségük alfacsatornára. Ezzel csökkenthető a teljes fájlméret, a kisebb fájlméretek pedig gyorsabb letöltést és zökkenőmentesebb interakciókat tesznek lehetővé.

A legjobb, ha a fájlméret legfeljebb 4 MB.

GLB-fájl létrehozása

  1. Látogasson el a https://glb-packer-old.glitch.me/ webhelyre.
  2. Húzza a Substance Painterből exportált fájlokat a GLB Packer weboldalára.

Egy out.glb nevű fájl töltődik le a számítógépére. A letöltés befejezése után átnevezheti a fájlt, majd feltöltheti a Shopifyba.