Izrada GLB datoteka pomoću programa Maya i Substance Painter
Možete upotrijebiti programe Maya i Substance Painter za izvoz GLB datoteke koja se može dodati proizvodu u administratorskom alatu za Shopify. 3D modeli mogu pomoći korisnicima da vizualiziraju proizvode, što može povećati povjerenje i smanjiti povrate.
Na ovoj stranici
Priprema modela za izvoz u programu Maya
Da biste pripremili model za izvoz, provjerite radi li se o jednoj mreži (mesh) na koju je primijenjen samo jedan materijal.
Koraci:
- Uvezite model u program Maya tako da otvorite File > Import..., odaberete 3D datoteku i zatim kliknete Import.
- Kliknite Mesh > Combine kako biste spojili mrežu u jedan objekt.
- Rasporedite model u UV prostor 0 – 1. Pazite da se UV koordinate ne preklapaju:

- Primijenite materijal Phong na model:
- Zadržite pokazivač miša iznad modela, pritisnite i držite desnu tipku miša, a zatim odaberite Assign New Material...
- U dijaloškom okviru odaberite Phong.
Izvoz mreže iz programa Maya
- Odaberite cijelu mrežu, a zatim kliknite File > Export Selection...
- Unesite naziv datoteke i lokaciju na koju je treba spremiti.
- Iz padajućeg izbornika Files of type odaberite OBJexport.
- Kliknite Export Selection.
Uvoz i priprema OBJ datoteke u programu Substance Painter
- Izradite novi projekt u programu Substance Painter klikom na File > New.
- U dijaloškom okviru New project kliknite Select da biste odabrali mrežu.
- Odaberite OBJ datoteku koju ste izvezli iz programa Maya, a zatim kliknite Open.
- U prozoru New project kliknite OK.
- Provjerite jeste li ispravno izvezli mrežu tako da se uvjerite da postoji samo jedan set tekstura na ploči Texture set list .
- Ako je prikazano više od jednog seta tekstura, pogledajte odjeljak Više setova tekstura.
- Na ploči Texture set settings kliknite gumb
+da biste dodali kanale:
- Obavezno: Ambient occlusion.
- Neobavezno: Emissive. Dodajte ovaj kanal ako vaš model ima komponente koje će emitirati svjetlost.
- Neobavezno: Opacity. Dodajte ovaj kanal ako vaš model ima komponente koje će biti prozirne.
- Na ploči Texture set settings kliknite Bake Mesh Maps.
- Nanesite teksture na model.
Više setova tekstura
Prilikom uvoza OBJ datoteke u program Substance Painter, trebao bi postojati samo jedan set tekstura:

Ako je prikazano više od jednog seta tekstura, znači da je nešto od sljedećeg pošlo po zlu prilikom izvoza mreže iz programa Maya:
- Mreža nije spojena u jedan objekt.
- Mreži je dodijeljeno više od jedne teksture.
U tom slučaju ponovno izvezite model iz programa Maya i uvjerite se da je mreža jedan objekt i da joj je dodijeljena samo jedna tekstura.
Izvoz glTF datoteke iz programa Substance Painter
Kliknite File > Export Textures.
Iz padajućeg izbornika Config odaberite glTF PBR Metal Roughness.
Odaberite lokaciju na koju želite spremiti teksture.
Odaberite veličinu dokumenta kako biste odredili veličinu datoteka tekstura.
Kliknite Export.
Sažimanje datoteka tekstura
Kada izvezete model, trebali biste imati sljedeće datoteke:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Kada upotrebljavate konfiguraciju glTF PBR Metal Roughness, program Substance Painter izvozi datoteke tekstura isključivo u formatu PNG. Razmislite o sažimanju datoteka tekstura i pretvaranju svih tekstura kojima nije potreban alfa kanal u format JPG. Time se smanjuje ukupna veličina datoteke, a manje datoteke omogućuju brže preuzimanje i fluidnije interakcije.
Najbolje je zadržati veličinu datoteke na 4 MB ili manje.
Izrada GLB datoteke
- Posjetite https://glb-packer-old.glitch.me/.
- Povucite i ispustite datoteke koje ste izvezli iz programa Substance Painter na web-stranicu GLB Packer.
Datoteka pod nazivom out.glb preuzet će se na vaše računalo. Nakon dovršetka preuzimanja datoteku možete preimenovati i prenijeti na platformu Shopify.