Maya और Substance Painter का उपयोग करके GLB फ़ाइल बनाना.

आप Shopify एडमिन में किसी प्रोडक्ट में जोड़ी जा सकने वाली GLB फ़ाइल एक्सपोर्ट करने के लिए Maya और Substance Painter का उपयोग कर सकते हैं। 3D मॉडल ग्राहकों को प्रोडक्ट को विज़ुअलाइज़ करने में मदद कर सकते हैं, जिससे उनका आत्मविश्वास बढ़ सकता है और रिटर्न कम हो सकते हैं।

Maya में एक्सपोर्ट के लिए अपना मॉडल तैयार करें.

एक्सपोर्ट के लिए अपना मॉडल तैयार करने के लिए, आपको यह पक्का करना होगा कि यह एक सिंगल मेश है और इस पर एक सिंगल मटेरियल लागू किया गया है।

चरण:

  1. File > Import... पर जाकर, अपनी 3D फ़ाइल चुनकर और फिर Import पर क्लिक करके, अपने मॉडल को Maya में इंपोर्ट करें।
  2. अपने मेश को एक ऑब्जेक्ट में कंबाइन करने के लिए Mesh > Combine पर क्लिक करें।
  3. मॉडल को 0-1 UV स्पेस में अनरैप करें। सुनिश्चित करें कि कोई भी UV ओवरलैप न हो:
    X और Y अक्ष पर 0 और 1 के बीच UV को लेआउट करने के लिए UV एडिटर का उपयोग करें।
  4. मॉडल पर एक Phong मटेरियल लागू करें:
    1. मॉडल पर अपने माउस कर्सर के साथ, राइट-क्लिक करें और होल्ड करें, और फिर Assign New Material... चुनें।
    2. डायलॉग से, Phong चुनें।

Maya से मेश एक्सपोर्ट करें.

  1. पूरे मेश को चुनें और फिर File > Export Selection... पर क्लिक करें।
  2. एक फ़ाइल नाम और वह लोकेशन डालें जहां फ़ाइल सेव की जानी चाहिए।
  3. Files of type ड्रॉप-डाउन मेनू से, OBJexport चुनें।
  4. Export Selection पर क्लिक करें।

Substance Painter में OBJ फ़ाइल इंपोर्ट करें और तैयार करें.

  1. File > New पर क्लिक करके एक नया Substance Painter प्रोजेक्ट बनाएं।
  2. New project डायलॉग में, मेश चुनने के लिए Select पर क्लिक करें।
  3. Maya से एक्सपोर्ट की गई OBJ फ़ाइल चुनें और फिर Open पर क्लिक करें।
  4. New project विंडो में, OK पर क्लिक करें।
  5. यह जांच करके सत्यापित करें कि आपने अपना मेश सही ढंग से एक्सपोर्ट किया है और टेक्सचर सेट लिस्ट पैनल में केवल एक टेक्सचर सेट है।
  6. टेक्सचर सेट सेटिंग पैनल में, + बटन पर क्लिक करके चैनल जोड़ें:
    + बटन चैनल हेडिंग के बगल में है। बटन एक ड्रॉप-डाउन मेनू खोलता है जो उपलब्ध अतिरिक्त चैनल दिखाता है।
    • ज़रूरी: एंबियंट ऑक्लूज़न।
    • वैकल्पिक: एमिसिव। अगर आपके मॉडल में ऐसे कॉम्पोनेंट हैं जो रोशनी उत्सर्जित करेंगे, तो इस चैनल को जोड़ें।
    • वैकल्पिक: ओपेसिटी। अगर आपके मॉडल में ऐसे कॉम्पोनेंट हैं जो पारदर्शी होंगे, तो इस चैनल को जोड़ें।
  7. टेक्सचर सेट सेटिंग पैनल में, Bake Mesh Maps पर क्लिक करें।
  8. मॉडल पर टेक्सचर पेंट करें।

एक से ज़्यादा टेक्सचर सेट.

जब आप OBJ फ़ाइल को Substance Painter में इंपोर्ट करते हैं, तो केवल एक टेक्सचर सेट होना चाहिए:

टेक्सचर सेट, टेक्सचर सेट सूची पैनल में सूचीबद्ध हैं.

अगर एक से ज़्यादा टेक्सचर सेट दिखाई देते हैं, तो Maya से मेश एक्सपोर्ट करते समय निम्न में से कोई एक गलती हुई थी:

  • मेश को एक ऑब्जेक्ट में नहीं जोड़ा गया था.
  • मेश को एक से ज़्यादा टेक्सचर असाइन किया गया था.

अगर ऐसा है, तो Maya से अपने मॉडल को फिर से एक्सपोर्ट करें और पक्का करें कि मेश एक ही ऑब्जेक्ट है और उसे केवल एक ही टेक्सचर असाइन किया गया है.

Substance Painter से glTF फ़ाइल एक्सपोर्ट करें

  1. फ़ाइल > एक्सपोर्ट टेक्सचर पर क्लिक करें.

  2. कॉन्फिग ड्रॉप-डाउन मेनू से, glTF PBR मेटल रफनेस चुनें.

  3. वह लोकेशन चुनें जहां आप अपने टेक्सचर सेव करना चाहते हैं.

  4. टेक्सचर फ़ाइलों का आकार तय करने के लिए दस्तावेज़ का साइज़ चुनें.

  5. एक्सपोर्ट करें पर क्लिक करें.

टेक्सचर फ़ाइल कंप्रेस करना

जब आप मॉडल एक्सपोर्ट कर लेते हैं, तो आपके पास निम्न फ़ाइल होनी चाहिए:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

glTF PBR मेटल रफनेस कॉन्फ़िगरेशन का उपयोग करते समय, Substance Painter सिर्फ़ PNG फ़ॉर्मेट में टेक्सचर फ़ाइल एक्सपोर्ट करता है. टेक्सचर फ़ाइल को कंप्रेस करने और ऐसे किसी भी टेक्सचर को JPG में बदलने पर विचार करें, जिसके लिए अल्फ़ा चैनल की ज़रूरत नहीं है. इससे कुल फ़ाइल साइज़ कम हो जाता है और छोटी फ़ाइलें तेज़ी से डाउनलोड होती हैं और इंटरैक्शन को आसान बनाती हैं.

यह सबसे अच्छा है कि आप अपनी फ़ाइल का साइज़ 4 एमबी या उससे कम रखें.

GLB फ़ाइल बनाएं

  1. https://glb-packer-old.glitch.me/ पर जाएं.
  2. Substance Painter से एक्सपोर्ट की गई फ़ाइलों को GLB पैकर वेब पेज पर खींचें और छोड़ें.

आपके कंप्यूटर पर out.glb नामक एक फ़ाइल डाउनलोड हो जाएगी. डाउनलोड पूरा होने के बाद, आप फ़ाइल का नाम बदल सकते हैं और फिर उसे Shopify पर अपलोड कर सकते हैं.