יצירת קובצי GLB באמצעות Maya ו-Substance Painter

אפשר להשתמש ב-Maya וב-Substance Painter כדי לייצא קובץ GLB שניתן להוסיף למוצר במנהל של Shopify. מודלים תלת-ממדיים יכולים לעזור ללקוחות להמחיש מוצרים, מה שיכול להגביר את הביטחון ולצמצם החזרות.

הכנת המודל לייצוא ב-Maya

כדי להכין את המודל לייצוא, יש לוודא שהוא בנוי כ-mesh יחיד ושהוחל עליו חומר אחד בלבד.

שלבים:

  1. כדי לייבא את המודל ל-Maya, יש לעבור אל File > Import..., לבחור את קובץ התלת-ממד ואז ללחוץ על Import.
  2. יש ללחוץ על Mesh > Combine כדי לשלב את ה-mesh לאובייקט יחיד.
  3. יש לפרוס (Unwrap) את המודל במרחב UV של 0-1. יש לוודא שאין מיפויי UV חופפים:
    שימוש בעורך ה-UV לפריסת מיפויי ה-UV בין 0 ל-1 בצירים X ו-Y.
  4. החלת חומר מסוג Phong על המודל:
    1. כאשר סמן העכבר נמצא מעל המודל, יש ללחוץ על הלחצן הימני ולהחזיק אותו, ולאחר מכן לבחור ב-Assign New Material...
    2. בתיבת הדו-שיח, יש לבחור ב-Phong.

ייצוא ה-mesh מ-Maya

  1. יש לבחור את כל ה-mesh, ולאחר מכן ללחוץ על File > Export Selection...
  2. יש להזין שם קובץ ואת המיקום שבו הקובץ יישמר.
  3. בתפריט הנפתח Files of type, יש לבחור ב-OBJexport.
  4. יש ללחוץ על Export Selection.

ייבוא והכנת קובץ ה-OBJ ב-Substance Painter

  1. יש ליצור פרויקט חדש ב-Substance Painter על ידי לחיצה על File > New.
  2. בתיבת הדו-שיח New project, יש ללחוץ על Select כדי לבחור mesh.
  3. יש לבחור את קובץ ה-OBJ שיוצא מ-Maya, ולאחר מכן ללחוץ על Open.
  4. בחלון New project, יש ללחוץ על OK.
  5. יש לוודא שה-mesh יוצא כראוי על ידי בדיקה שיש רק סט מרקמים אחד בחלונית ה- Texture set list .
  6. בחלונית Texture set settings , יש ללחוץ על הלחצן + כדי להוסיף ערוצים:
    הלחצן + נמצא לצד הכותרת Channels. הלחצן פותח תפריט נפתח שמציג את הערוצים הנוספים הזמינים.
    • חובה: Ambient occlusion.
    • אופציונלי: Emissive. יש להוסיף ערוץ זה אם למודל יש רכיבים שיפלטו אור.
    • אופציונלי: Opacity. יש להוסיף ערוץ זה אם למודל יש רכיבים שיהיו שקופים.
  7. בחלונית Texture set settings, יש ללחוץ על Bake Mesh Maps.
  8. צביעת מרקמים על המודל.

ריבוי סטי מרקמים

בעת ייבוא קובץ ה-OBJ ל-Substance Painter, אמור להיות רק סט מרקמים אחד:

ערכות מרקמים מפורטות בחלונית רשימת ערכות המרקמים (Texture set list).

אם מוצגת יותר מערכת מרקמים אחת, אחת מהשגיאות הבאות התרחשה בעת ייצוא הרשת (mesh) מ-Maya:

  • הרשת לא שולבה לאובייקט יחיד.
  • לרשת הוקצה יותר ממרקם אחד.

במקרה כזה, יש לייצא את המודל מ-Maya שוב ולוודא שהרשת היא אובייקט יחיד ושמוקצה לה מרקם יחיד בלבד.

ייצוא של קובץ glTF מ-Substance Painter

  1. יש ללחוץ על File > Export Textures.

  2. מהתפריט הנפתח Config, יש לבחור באפשרות glTF PBR Metal Roughness.

  3. יש לבחור את המיקום שבו רוצים לשמור את המרקמים.

  4. יש לבחור גודל מסמך כדי לקבוע את הגודל של קובצי המרקמים.

  5. יש ללחוץ על Export.

דחיסת קובצי מרקמים

לאחר ייצוא המודל, צריכים להתקבל הקבצים הבאים:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

בעת שימוש בתצורת glTF PBR Metal Roughness, התוכנה Substance Painter מייצאת קובצי מרקם בפורמט PNG בלבד. כדאי לשקול דחיסה של קובצי המרקם והמרה של מרקמים שאינם דורשים ערוץ אלפא לפורמט JPG. פעולה זו מקטינה את הגודל הכולל של הקובץ, וקבצים קטנים יותר מאפשרים מהירויות הורדה גבוהות יותר ואינטראקציה חלקה יותר.

מומלץ לשמור על גודל קובץ של 4 MB לכל היותר.

יצירת קובץ GLB

  1. יש להיכנס אל https://glb-packer-old.glitch.me/.
  2. יש לגרור ולשחרר את הקבצים שיוצאו מ-Substance Painter אל דף האינטרנט של GLB Packer.

קובץ בשם out.glb יורד למחשב. לאחר סיום ההורדה, ניתן לשנות את שם הקובץ ולאחר מכן להעלות אותו אל Shopify.