GLB-tiedostojen luominen Maya- ja Substance Painter -ohjelmilla

Voit viedä GLB-tiedoston Maya- ja Substance Painter -ohjelmilla. Tiedoston voi lisätä tuotteeseen Shopifyn ohjausnäkymässä. 3D-mallit auttavat asiakkaita visualisoimaan tuotteita, mikä voi lisätä luottamusta ja vähentää palautuksia.

Mallin valmisteleminen vientiä varten Mayassa

Jotta voit valmistella mallisi vientiä varten, sinun on varmistettava, että se on yksi yhtenäinen verkko ja että siihen on sovellettu vain yhtä materiaalia.

Vaiheet:

  1. Tuo mallisi Mayaan valitsemalla File > Import..., valitse 3D-tiedostosi ja klikkaa sitten Import.
  2. Yhdistä verkkosi yhdeksi objektiksi valitsemalla Mesh > Combine.
  3. Pura malli 0–1 UV-avaruuteen. Varmista, että UV-alueet eivät ole päällekkäin:
    Asettele UV-alueet UV Editorilla X- ja Y-akselien välille 0 ja 1.
  4. Sovella Phong-materiaalia malliin:
    1. Vie hiiren osoitin mallin päälle, napsauta hiiren kakkospainiketta ja pidä se alhaalla ja valitse sitten Assign New Material...
    2. Valitse valintaikkunasta Phong.

Verkon vieminen Mayasta

  1. Valitse koko verkko ja klikkaa sitten File > Export Selection...
  2. Anna tiedostonimi ja sijainti, johon tiedosto tallennetaan.
  3. Valitse Tiedostotyypit-pudotusvalikosta OBJexport.
  4. Klikkaa Export Selection.

OBJ-tiedoston tuominen ja valmisteleminen Substance Painterissa

  1. Luo uusi Substance Painter -projekti klikkaamalla File > New.
  2. Klikkaa Uusi projekti -valintaikkunassa Select-painiketta verkon valitsemiseksi.
  3. Valitse Mayasta viemäsi OBJ-tiedosto ja klikkaa sitten Open.
  4. Klikkaa Uusi projekti -ikkunassa OK.
  5. Varmista, että olet vienyt verkkosi oikein tarkistamalla, että Tekstuurijoukkojen luettelo -paneelissa on vain yksi tekstuurijoukko.
  6. Klikkaa Tekstuurijoukon asetukset -paneelissa olevaa + -painiketta lisätäksesi kanavia:
    +-painike on Kanavat-otsikon vieressä. Painike avaa pudotusvalikon, jossa näkyvät käytettävissä olevat lisäkanavat.
    • Pakollinen: Ambient occlusion.
    • Valinnainen: Emissive. Lisää tämä kanava, jos mallissasi on valoa säteileviä komponentteja.
    • Valinnainen: Opacity. Lisää tämä kanava, jos mallissasi on läpinäkyviä komponentteja.
  7. Klikkaa Tekstuurijoukon asetukset -paneelissa Bake Mesh Maps.
  8. Maalaa tekstuurit malliin.

Useita tekstuurijoukkoja

Kun tuot OBJ-tiedoston Substance Painteriin, tekstuurijoukkoja pitäisi olla vain yksi:

Tekstuurisarjat on lueteltu Texture set list -paneelissa.

Jos näkyviin tulee useampi kuin yksi tekstuurisarja, jokin seuraavista asioista meni pieleen, kun mesh-verkko vietiin Mayasta:

  • Mesh-verkkoa ei yhdistetty yksittäiseksi objektiksi.
  • Mesh-verkkoon oli määritetty useampi kuin yksi tekstuuri.

Jos näin on, vie mallisi uudelleen Mayasta ja varmista, että mesh-verkko on yksittäinen objekti ja että sille on määritetty vain yksi tekstuuri.

Vie glTF-tiedosto Substance Painterista

  1. Valitse File > Export Textures.

  2. Valitse Config-pudotusvalikosta glTF PBR Metal Roughness.

  3. Valitse sijainti, johon haluat tallentaa tekstuurisi.

  4. Valitse asiakirjan koko, joka määrittää, kuinka suuria tekstuuritiedostoista tulee.

  5. Klikkaa Export.

Tekstuuritiedostojen pakkaaminen

Kun olet vienyt mallin, sinulla pitäisi olla seuraavat tiedostot:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Kun käytät glTF PBR Metal Roughness -määritystä, Substance Painter vie tekstuuritiedostot vain PNG-muodossa. Harkitse tekstuuritiedostojen pakkaamista ja sellaisten tekstuurien muuntamista JPG-muotoon, jotka eivät tarvitse alfakanavaa. Tämä pienentää tiedoston kokonaiskokoa, ja pienemmät tiedostokoot mahdollistavat nopeammat latausnopeudet ja sujuvammat interaktiot.

Tiedostokoon on parasta olla enintään 4 Mt.

GLB-tiedoston luominen

  1. Siirry osoitteeseen https://glb-packer-old.glitch.me/.
  2. Vedä ja pudota Substance Painterista viemäsi tiedostot GLB Packer -verkkosivulle.

Tietokoneellesi ladataan tiedosto nimeltä out.glb. Kun lataus on valmis, voit nimetä tiedoston uudelleen ja ladata sen Shopifyhin.