Crear archivos GLB con Maya y Substance Painter
Puedes usar Maya y Substance Painter para exportar un archivo GLB que puedes agregar a un producto en el panel de control de Shopify. Los modelos 3D pueden ayudar a los clientes a visualizar los productos, lo que puede aumentar la confianza y reducir las devoluciones.
En esta página
Prepara el modelo para la exportación en Maya
Para preparar el modelo para la exportación, asegúrate de que sea una sola malla y que tenga un único material aplicado.
Pasos:
- Para importar el modelo en Maya, ve a File > Import..., elige el archivo 3D y luego haz clic en Import.
- Haz clic en Mesh > Combine para combinar la malla en un solo objeto.
- Despliega el modelo en el espacio UV 0-1. Asegúrate de que no haya UV superpuestas:

- Aplica un material Phong al modelo:
- Con el cursor del mouse sobre el modelo, haz clic con el botón derecho y manténlo presionado, y luego selecciona Assign New Material...
- En el cuadro de diálogo, selecciona Phong.
Exportar la malla desde Maya
- Selecciona toda la malla y luego haz clic en File > Export Selection...
- Ingresa un nombre de archivo y la ubicación donde se debe guardar.
- En el menú desplegable Files of type, selecciona OBJexport.
- Haz clic en Export Selection.
Importar y preparar el archivo OBJ en Substance Painter
- Crea un proyecto nuevo de Substance Painter haciendo clic en File > New.
- En el cuadro de diálogo New project, haz clic en Select para elegir una malla.
- Selecciona el archivo OBJ que exportaste desde Maya y luego haz clic en Open.
- En la ventana New project, haz clic en OK.
- Verifica que exportaste la malla correctamente comprobando que solo haya un conjunto de texturas en el Texture set list panel.
- Si se muestra más de un conjunto de texturas, consulta Varios conjuntos de texturas.
- En el Texture set settings panel, haz clic en el
+botón para agregar canales:
- Obligatorio: oclusión ambiental.
- Opcional: emisivo. Agrega este canal si el modelo tiene componentes que emiten luz.
- Opcional: opacidad. Agrega este canal si el modelo tiene componentes que serán transparentes.
- En el panel Texture set settings, haz clic en Bake Mesh Maps.
- Pinta las texturas sobre el modelo.
Varios conjuntos de texturas
Cuando importes el archivo OBJ en Substance Painter, debe haber un solo conjunto de texturas:

Si se muestra más de un conjunto de texturas, entonces ocurrió alguno de los siguientes problemas al exportar la malla desde Maya:
- La malla no se combinó en un solo objeto.
- La malla tenía asignada más de una textura.
Si es así, vuelve a exportar el modelo desde Maya y asegúrate de que la malla sea un solo objeto y tenga asignada solo una textura.
Exporta el archivo glTF desde Substance Painter
Haz clic en File > Export Textures.
En el menú desplegable Config, selecciona glTF PBR Metal Roughness.
Elige la ubicación donde quieres guardar las texturas.
Elige un tamaño de documento para definir el tamaño de los archivos de textura.
Haz clic en Export.
Compresión de archivos de textura
Después de exportar el modelo, deberías tener los siguientes archivos:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Cuando usas la configuración glTF PBR Metal Roughness, Substance Painter exporta las texturas solo en formato PNG. Considera comprimir los archivos de textura y convertir a JPG las texturas que no necesitan canal alfa. Así reduces el tamaño total de los archivos y, cuanto más pequeños sean, más rápidas serán las descargas y más fluidas las interacciones.
Lo ideal es mantener el tamaño del archivo en 4 MB o menos.
Crea un archivo GLB
- Visita https://glb-packer-old.glitch.me/.
- Arrastra y suelta en la página web de GLB Packer los archivos que exportaste desde Substance Painter.
Se descargará un archivo llamado out.glb en la computadora. Cuando termine la descarga, puedes cambiarle el nombre al archivo y luego subirlo a Shopify.