Crear archivos GLB con 3ds Max y Substance Painter

Puedes usar 3ds Max y Substance Painter para exportar un archivo GLB que se pueda agregar a un producto en el panel de control de Shopify. Los modelos 3D pueden ayudar a que los clientes visualicen los productos, lo que puede aumentar la confianza y reducir las devoluciones.

Prepara el modelo para exportarlo en 3ds Max

Para preparar el modelo para la exportación, asegúrate de que sea una sola malla y que tenga aplicado un único material.

Pasos:

  1. Haz clic en Archivo > Importar... > Importar....
  2. Selecciona el archivo del modelo y haz clic en Abrir.
  3. En el cuadro de diálogo Opciones de importación de OBJ, marca Importar como una sola malla.
  4. Haz clic en Importar.
  5. Despliega el modelo en el espacio 0-1. Asegúrate de que las UV no se superpongan:
    Usa el editor Edit UVWs para distribuir las UV entre 0 y 1 en los ejes X e Y.
  6. Aplica un único material a todo el modelo.

Exporta la malla desde 3ds Max

  1. Haz clic en Archivo > Exportar > Exportar...
  2. Ingresa un nombre de archivo y la ubicación donde quieres exportar el modelo.
  3. En el menú desplegable Guardar como tipo, selecciona OBJ-Export (.OBJ).
  4. Haz clic en Guardar.
  5. En el cuadro de diálogo Opciones de exportación de OBJ, deja las opciones predeterminadas y haz clic en Exportar.

Importa y prepara el archivo OBJ en Substance Painter

  1. Crea un proyecto nuevo en Substance Painter haciendo clic en Archivo > Nuevo.
  2. En el diálogo New project, haz clic en Select para elegir una malla.
  3. Selecciona el archivo OBJ que exportaste desde 3ds Max y haz clic en Open.
  4. En la ventana New project, haz clic en OK.
  5. Verifica que la malla se exportó correctamente comprobando que haya solo un conjunto de texturas en el Texture set list panel.
  6. En el Texture set settings panel, haz clic en el + botón para agregar canales:
    El botón + está junto al encabezado Channels. El botón abre un menú desplegable que muestra los canales adicionales que están disponibles.
    • Obligatorio: Ambient occlusion.
    • Opcional: Emissive. Agrega este canal si el modelo tiene componentes que emiten luz.
    • Opcional: Opacity. Agrega este canal si el modelo tiene componentes que sean transparentes.
  7. En el panel Texture set settings, haz clic en Bake Mesh Maps.
  8. Pinta las texturas sobre el modelo.

Varios conjuntos de texturas

Cuando importas el archivo OBJ en Substance Painter, debe haber solo un conjunto de texturas:

Los conjuntos de texturas se muestran en el panel Texture set list.

Si se muestra más de un conjunto de texturas, entonces ocurrió alguno de los siguientes errores al exportar la malla desde 3ds Max:

  • La malla no se combinó en un solo objeto.
  • La malla tenía más de una textura asignada.

En ese caso, vuelve a exportar el modelo desde 3ds Max y asegúrate de que la malla sea un solo objeto y tenga solo una textura asignada.

Exportar el archivo glTF desde Substance Painter

  1. Haz clic en File > Export Textures.

  2. En el menú desplegable Config, selecciona glTF PBR Metal Roughness.

  3. Elige la ubicación donde quieres guardar las texturas.

  4. Elige un tamaño de documento para definir qué tan grandes serán los archivos de textura.

  5. Haz clic en Export.

Comprimir archivos de textura

Cuando exportes el modelo, deberías tener los siguientes archivos:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Al usar la configuración glTF PBR Metal Roughness, Substance Painter exporta los archivos de textura solo en formato PNG. Considera comprimir las texturas y convertir las que no necesiten canal alfa a JPG. Esto reduce el tamaño total del archivo, y los archivos más pequeños permiten descargas más rápidas e interacciones más fluidas.

Lo ideal es mantener el tamaño del archivo en 4 MB o menos.

Crear un archivo GLB

  1. Visita https://glb-packer-old.glitch.me/.
  2. Arrastra y suelta los archivos exportados desde Substance Painter en la página web de GLB Packer.

Se descargará en la computadora un archivo llamado out.glb. Cuando termine la descarga, puedes renombrar el archivo y subirlo a Shopify.