Δημιουργία αρχείων GLB με χρήση των Maya και Substance Painter
Μπορείτε να χρησιμοποιήσετε τα Maya και Substance Painter για να εξαγάγετε ένα αρχείο GLB που μπορεί να προστεθεί σε ένα προϊόν στον διαχειριστή του Shopify. Τα μοντέλα 3D μπορούν να βοηθήσουν τους πελάτες να οπτικοποιήσουν τα προϊόντα, γεγονός που μπορεί να αυξήσει την εμπιστοσύνη και να μειώσει τις επιστροφές.
Σε αυτήν τη σελίδα
Προετοιμασία του μοντέλου σας για εξαγωγή στο Maya
Για να προετοιμάσετε το μοντέλο σας για εξαγωγή, πρέπει να βεβαιωθείτε ότι είναι ένα μεμονωμένο πλέγμα και ότι έχει ένα μόνο υλικό που εφαρμόζεται σε αυτό.
Βήματα:
- Εισαγάγετε το μοντέλο σας στο Maya μεταβαίνοντας στα File > Import..., επιλέγοντας το αρχείο 3D και, στη συνέχεια, κάνοντας κλικ στο Import.
- Κάντε κλικ στα Mesh > Combine για να συνδυάσετε το πλέγμα σας σε ένα ενιαίο αντικείμενο.
- Ξετυλίξτε το μοντέλο στον χώρο UV 0-1. Βεβαιωθείτε ότι δεν επικαλύπτονται UV:

- Εφαρμόστε ένα υλικό Phong στο μοντέλο:
- Με τον κέρσορα του ποντικιού πάνω από το μοντέλο, κάντε δεξί κλικ και κρατήστε πατημένο και, στη συνέχεια, επιλέξτε Assign New Material...
- Από το πλαίσιο διαλόγου, επιλέξτε Phong.
Εξαγωγή του πλέγματος από το Maya
- Επιλέξτε ολόκληρο το πλέγμα και, στη συνέχεια, κάντε κλικ στα File > Export Selection...
- Εισαγάγετε ένα όνομα αρχείου και την τοποθεσία όπου θα πρέπει να αποθηκευτεί το αρχείο.
- Από το αναπτυσσόμενο μενού Files of type, επιλέξτε OBJexport.
- Κάντε κλικ στο Export Selection.
Εισαγωγή και προετοιμασία του αρχείου OBJ στο Substance Painter
- Δημιουργήστε ένα νέο έργο Substance Painter κάνοντας κλικ στα File > New.
- Στο πλαίσιο διαλόγου New project, κάντε κλικ στο Select για να επιλέξετε ένα πλέγμα.
- Επιλέξτε το αρχείο OBJ που εξαγάγατε από το Maya και, στη συνέχεια, κάντε κλικ στο Open.
- Στο παράθυρο New project, κάντε κλικ στο OK.
- Επαληθεύστε ότι εξαγάγατε σωστά το πλέγμα σας, ελέγχοντας ότι υπάρχει μόνο ένα σύνολο υφών στον πίνακα Texture set list .
- Εάν εμφανίζονται περισσότερα από ένα σύνολα υφών, τότε ανατρέξτε στην ενότητα Πολλαπλά σύνολα υφών.
- Στον πίνακα Texture set settings , κάντε κλικ στο κουμπί
+για να προσθέσετε κανάλια:
- Απαιτείται: Ambient occlusion.
- Προαιρετικό: Emissive. Προσθέστε αυτό το κανάλι εάν το μοντέλο σας έχει συστατικά που θα εκπέμπουν φως.
- Προαιρετικό: Opacity. Προσθέστε αυτό το κανάλι εάν το μοντέλο σας έχει συστατικά που θα είναι διαφανή.
- Στον πίνακα Texture set settings, κάντε κλικ στο Bake Mesh Maps.
- Ζωγραφίστε υφές πάνω στο μοντέλο.
Πολλαπλά σύνολα υφών
Όταν εισάγετε το αρχείο OBJ στο Substance Painter, θα πρέπει να υπάρχει μόνο ένα σύνολο υφών:

Αν εμφανίζεται περισσότερα από ένα σύνολα υφής, τότε ένα από τα παρακάτω δεν έγινε σωστά κατά την εξαγωγή του πλέγματος από το Maya:
- Το πλέγμα δεν συνδυάστηκε σε ένα ενιαίο αντικείμενο.
- Στο πλέγμα είχαν αντιστοιχιστεί περισσότερες από μία υφές.
Αν ισχύει αυτό, τότε εξάγετε ξανά το μοντέλο σας από το Maya και βεβαιωθείτε ότι το πλέγμα είναι ένα ενιαίο αντικείμενο και ότι του έχει αντιστοιχιστεί μόνο μία υφή.
Εξαγωγή του αρχείου glTF από το Substance Painter
Κάντε κλικ στο Αρχείο > Εξαγωγή υφών.
Από το αναπτυσσόμενο μενού Διαμόρφωση, επιλέξτε glTF PBR Metal Roughness.
Επιλέξτε την τοποθεσία όπου θέλετε να αποθηκεύσετε τις υφές σας.
Επιλέξτε ένα μέγεθος εγγράφου για να καθορίσετε το μέγεθος των αρχείων υφής.
Κάντε κλικ στο Εξαγωγή.
Συμπίεση αρχείων υφής
Όταν εξαγάγετε το μοντέλο, θα πρέπει να έχετε τα ακόλουθα αρχεία:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Όταν χρησιμοποιείτε τη διαμόρφωση glTF PBR Metal Roughness, το Substance Painter εξάγει αρχεία υφής μόνο σε μορφή PNG. Εξετάστε το ενδεχόμενο να συμπιέσετε τα αρχεία υφής και να μετατρέψετε σε JPG τυχόν υφές που δεν χρειάζονται κανάλι άλφα. Αυτό μειώνει το συνολικό μέγεθος αρχείου και τα μικρότερα μεγέθη αρχείων επιτρέπουν ταχύτερες λήψεις και ομαλότερες αλληλεπιδράσεις.
Είναι καλύτερο το μέγεθος του αρχείου σας να είναι 4 MB ή μικρότερο.
Δημιουργία αρχείου GLB
- Επισκεφθείτε τη διεύθυνση https://glb-packer-old.glitch.me/.
- Κάντε μεταφορά και απόθεση των αρχείων που εξαγάγατε από το Substance Painter στην ιστοσελίδα GLB Packer.
Ένα αρχείο με το όνομα out.glb θα ληφθεί στον υπολογιστή σας. Αφού ολοκληρωθεί η λήψη, μπορείτε να μετονομάσετε το αρχείο και στη συνέχεια να το μεταφορτώσετε στο Shopify.