Δημιουργία αρχείων GLB με χρήση του 3ds Max και του Substance Painter
Μπορείτε να χρησιμοποιήσετε το 3ds Max και το Substance Painter για να εξαγάγετε ένα αρχείο GLB που μπορεί να προστεθεί σε ένα προϊόν στον Διαχειριστή Shopify. Τα τρισδιάστατα μοντέλα μπορούν να βοηθήσουν τους πελάτες να οπτικοποιήσουν τα προϊόντα, γεγονός που μπορεί να αυξήσει την εμπιστοσύνη και να μειώσει τις επιστροφές.
Σε αυτήν τη σελίδα
Προετοιμασία του μοντέλου σας για εξαγωγή στο 3ds Max
Για να προετοιμάσετε το μοντέλο σας για εξαγωγή, πρέπει να βεβαιωθείτε ότι είναι ένα ενιαίο πλέγμα και ότι έχει εφαρμοστεί σε αυτό ένα μόνο υλικό.
Βήματα:
- Κάντε κλικ στο μενού File > Import... > Import....
- Επιλέξτε το αρχείο του μοντέλου σας και, στη συνέχεια, κάντε κλικ στο κουμπί Open.
- Στο παράθυρο διαλόγου OBJ Import Options, επιλέξτε το πλαίσιο ελέγχου Import as a single mesh.
- Κάντε κλικ στο κουμπί Import.
- Ξετυλίξτε το μοντέλο στον χώρο 0-1. Βεβαιωθείτε ότι δεν υπάρχει επικάλυψη των UV:

- Εφαρμόστε ένα ενιαίο υλικό σε ολόκληρο το μοντέλο.
Εξαγωγή του πλέγματος από το 3ds Max
- Κάντε κλικ στο μενού File > Export > Export...
- Εισαγάγετε ένα όνομα αρχείου και την τοποθεσία στην οποία θέλετε να εξαγάγετε το μοντέλο.
- Από το αναπτυσσόμενο μενού Save as Type, επιλέξτε OBJ-Export (.OBJ).
- Κάντε κλικ στο κουμπί Save.
- Στο παράθυρο διαλόγου OBJ Export Options, αφήστε τις προεπιλεγμένες επιλογές ως έχουν και κάντε κλικ στο κουμπί Export.
Εισαγωγή και προετοιμασία του αρχείου OBJ στο Substance Painter
- Δημιουργήστε ένα νέο έργο του Substance Painter κάνοντας κλικ στο μενού File > New.
- Στο παράθυρο διαλόγου Νέο έργο, κάντε κλικ στην επιλογή Επιλογή για να επιλέξετε ένα πλέγμα.
- Επιλέξτε το αρχείο OBJ που εξαγάγατε από το 3ds Max και, στη συνέχεια, κάντε κλικ στην επιλογή Άνοιγμα.
- Στο παράθυρο Νέο έργο, κάντε κλικ στο κουμπί OK.
- Επαληθεύστε ότι εξαγάγατε σωστά το πλέγμα σας, ελέγχοντας ότι υπάρχει μόνο ένα σύνολο υφών στον Λίστα συνόλων υφών πίνακα.
- Αν εμφανίζονται περισσότερα από ένα σύνολα υφών, τότε ανατρέξτε στην ενότητα Πολλαπλά σύνολα υφών.
- Στον Ρυθμίσεις συνόλου υφών πίνακα, κάντε κλικ στο
+κουμπί για να προσθέσετε κανάλια:
- Απαιτείται: Ατμοσφαιρική σκίαση.
- Προαιρετικό: Εκπεμψιμότητα. Προσθέστε αυτό το κανάλι εάν το μοντέλο σας έχει στοιχεία που θα εκπέμπουν φως.
- Προαιρετικό: Αδιαφάνεια. Προσθέστε αυτό το κανάλι εάν το μοντέλο σας έχει στοιχεία που θα είναι διαφανή.
- Στον πίνακα Ρυθμίσεις συνόλου υφών, κάντε κλικ στην επιλογή Δημιουργία χαρτών πλέγματος.
- Ζωγραφίστε υφές πάνω στο μοντέλο.
Πολλαπλά σύνολα υφών
Κατά την εισαγωγή του αρχείου OBJ στο Substance Painter, θα πρέπει να υπάρχει μόνο ένα σύνολο υφών:

Αν εμφανίζονται περισσότερα από ένα σύνολα υφών, τότε ένα από τα παρακάτω ήταν εσφαλμένο κατά την εξαγωγή του πλέγματος από το 3ds Max:
- Το πλέγμα δεν συνδυάστηκε σε ένα ενιαίο αντικείμενο.
- Στο πλέγμα είχαν αντιστοιχιστεί περισσότερες από μία υφές.
Σε αυτήν την περίπτωση, εξαγάγετε ξανά το μοντέλο σας από το 3ds Max και βεβαιωθείτε ότι το πλέγμα είναι ένα ενιαίο αντικείμενο και ότι σε αυτό έχει αντιστοιχιστεί μόνο μία υφή.
Εξαγωγή του αρχείου glTF από το Substance Painter
Κάντε κλικ στις επιλογές Αρχείο > Εξαγωγή υφών.
Από το αναπτυσσόμενο μενού Διαμόρφωση, επιλέξτε glTF PBR Metal Roughness.
Επιλέξτε την τοποθεσία όπου θέλετε να αποθηκεύσετε τις υφές σας.
Επιλέξτε ένα μέγεθος εγγράφου για να καθορίσετε πόσο μεγάλα θα είναι τα αρχεία υφής.
Κάντε κλικ στην επιλογή Εξαγωγή.
Συμπίεση αρχείων υφής
Μετά την εξαγωγή του μοντέλου, θα πρέπει να έχετε τα ακόλουθα αρχεία:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Όταν χρησιμοποιείτε τη διαμόρφωση glTF PBR Metal Roughness, το Substance Painter εξάγει αρχεία υφής μόνο σε μορφή PNG. Εξετάστε το ενδεχόμενο συμπίεσης των αρχείων υφής και μετατροπής τυχόν υφών που δεν χρειάζονται κανάλι άλφα σε JPG. Αυτό μειώνει το συνολικό μέγεθος του αρχείου και τα μικρότερα μεγέθη αρχείων επιτρέπουν ταχύτερες ταχύτητες λήψης και ομαλότερες αλληλεπιδράσεις.
Καλό είναι το μέγεθος του αρχείου σας να μην ξεπερνά τα 4 MB.
Δημιουργία αρχείου GLB
- Επισκεφτείτε τη διεύθυνση https://glb-packer-old.glitch.me/.
- Μεταφέρετε και αποθέστε τα αρχεία που εξαγάγατε από το Substance Painter στην ιστοσελίδα του GLB Packer.
Ένα αρχείο με την ονομασία out.glb θα ληφθεί στον υπολογιστή σας. Μόλις ολοκληρωθεί η λήψη, μπορείτε να μετονομάσετε το αρχείο και, στη συνέχεια, να το μεταφορτώσετε στο Shopify.