GLB-Dateien mit Maya und Substance Painter erstellen
Du kannst Maya und Substance Painter verwenden, um eine GLB-Datei zu exportieren, die im Shopify-Adminbereich zu einem Produkt hinzugefügt werden kann. 3D-Modelle können Kund:innen helfen, Produkte zu visualisieren, was das Vertrauen stärken und Rückgaben reduzieren kann.
Auf dieser Seite
Modell für den Export in Maya vorbereiten
Um dein Modell für den Export vorzubereiten, musst du sicherstellen, dass es ein einzelnes Mesh ist und dass ihm ein einziges Material zugewiesen ist.
Schritte:
- Importiere dein Modell in Maya, indem du zu Datei > Importieren... navigierst, deine 3D-Datei auswählst und dann auf Importieren klickst.
- Klicke auf Mesh > Kombinieren, um dein Mesh zu einem einzigen Objekt zu kombinieren.
- Entwickle das Modell in den 0-1-UV-Raum. Stelle sicher, dass sich keine UVs überlappen:

- Wende ein Phong-Material auf das Modell an:
- Halte den Mauszeiger über das Modell, klicke mit der rechten Maustaste und halte sie gedrückt und wähle dann Neues Material zuweisen ... aus.
- Wähle im Dialogfeld Phong aus.
Mesh aus Maya exportieren
- Wähle das gesamte Mesh aus und klicke dann auf Datei > Auswahl exportieren ...
- Gib einen Dateinamen und den Speicherort für die Datei ein.
- Wähle im Dropdown-Menü Dateityp die Option OBJexport aus.
- Klicke auf Auswahl exportieren.
OBJ-Datei in Substance Painter importieren und vorbereiten
- Erstelle ein neues Substance Painter-Projekt, indem du auf Datei > Neu klickst.
- Klicke im Dialogfeld Neues Projekt auf Auswählen, um ein Mesh auszuwählen.
- Wähle die OBJ-Datei aus, die du aus Maya exportiert hast, und klicke dann auf Öffnen.
- Klicke im Fenster Neues Projekt auf OK.
- Überprüfe, ob du dein Mesh korrekt exportiert hast, indem du kontrollierst, dass im Textursatzliste -Panel nur ein Textursatz vorhanden ist.
- Wenn mehr als ein Textursatz angezeigt wird, findest du weitere Informationen unter Mehrere Textursätze.
- Im Textursatzeinstellungen -Panel klicke auf die
+-Schaltfläche, um Kanäle hinzuzufügen:
- Erforderlich: Umgebungsverdeckung.
- Optional: Emission. Füge diesen Kanal hinzu, wenn dein Modell Komponenten hat, die Licht emittieren.
- Optional: Deckkraft. Füge diesen Kanal hinzu, wenn dein Modell Komponenten hat, die transparent sein sollen.
- Klicke im Panel Textursatzeinstellungen auf Bake Mesh Maps.
- Male Texturen auf das Modell.
Mehrere Textursätze
Wenn du die OBJ-Datei in Substance Painter importierst, sollte nur ein Textursatz vorhanden sein:

Wenn mehr als ein Textur-Set angezeigt wird, ist beim Exportieren des Meshs aus Maya einer der folgenden Fehler aufgetreten:
- Das Mesh wurde nicht zu einem einzelnen Objekt zusammengefügt.
- Dem Mesh wurde mehr als eine Textur zugewiesen.
Wenn das der Fall ist, exportiere dein Modell erneut aus Maya und stelle sicher, dass das Mesh ein einzelnes Objekt ist und ihm nur eine einzige Textur zugewiesen ist.
glTF-Datei aus Substance Painter exportieren
Klicke auf „Datei“ > „Texturen exportieren“.
Wähle im Dropdown-Menü „Config“ die Option „glTF PBR Metal Roughness“ aus.
Wähle den Speicherort für deine Texturen aus.
Wähle eine Dokumentgröße aus, um zu bestimmen, wie groß die Texturdateien sein werden.
Klicke auf „Exportieren“.
Texturdateien komprimieren
Wenn du das Modell exportiert hast, solltest du die folgenden Dateien haben:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Bei Verwendung der Konfiguration „glTF PBR Metal Roughness“ exportiert Substance Painter Texturdateien nur im PNG-Format. Du solltest in Betracht ziehen, die Texturdateien zu komprimieren und alle Texturen, die keinen Alphakanal benötigen, in das JPG-Format zu konvertieren. Dadurch wird die Gesamtdateigröße reduziert und kleinere Dateigrößen ermöglichen schnellere Download-Geschwindigkeiten und reibungslosere Interaktionen.
Deine Dateigröße sollte höchstens 4 MB betragen.
GLB-Datei erstellen
- Besuche https://glb-packer-old.glitch.me/.
- Ziehe die Dateien, die du aus Substance Painter exportiert hast, per Drag-and-Drop auf die Webseite von GLB Packer.
Eine Datei mit dem Namen out.glb wird auf deinen Computer heruntergeladen. Nachdem der Download abgeschlossen ist, kannst du die Datei umbenennen und sie dann bei Shopify hochladen.