Oprettelse af GLB-filer ved hjælp af Maya og Substance Painter
Du kan bruge Maya og Substance Painter til at eksportere en GLB-fil, der kan føjes til et produkt i Shopify-administratoren. 3D-modeller kan hjælpe kunder med at visualisere produkter, hvilket kan øge deres købssikkerhed og mindske antallet af returneringer.
På denne side
Forbered modellen til eksport i Maya
For at klargøre modellen til eksport skal du sikre dig, at den er et enkelt mesh, og at der er anvendt et enkelt materiale på den.
Fremgangsmåde:
- Importér modellen til Maya ved at gå til File > Import..., vælge 3D-filen og derefter klikke på Import.
- Klik på Mesh > Combine for at kombinere meshet til et enkelt objekt.
- Unwrap modellen til 0-1 UV-space. Sørg for, at ingen UV'er overlapper hinanden:

- Anvend et Phong-materiale på modellen:
- Hold musemarkøren over modellen, højreklik, hold knappen nede, og vælg derefter Assign New Material...
- Vælg Phong i dialogboksen.
Eksportér meshet fra Maya
- Vælg hele meshet, og klik derefter på File > Export Selection...
- Angiv et filnavn og den lokation, hvor filen skal gemmes.
- Vælg OBJexport i rullemenuen Files of type.
- Klik på Export Selection.
Importér og klargør OBJ-filen i Substance Painter
- Opret et nyt Substance Painter-projekt ved at klikke på File > New.
- Klik på Select i dialogboksen New project for at vælge et mesh.
- Vælg den OBJ-fil, du eksporterede fra Maya, og klik derefter på Open.
- Klik på OK i vinduet New project.
- Bekræft, at meshet er eksporteret korrekt, ved at kontrollere, at der kun er ét tekstursæt i Texture set list -panelet.
- Hvis der vises mere end ét tekstursæt, kan du se afsnittet Flere tekstursæt.
- I Texture set settings -panelet skal du klikke på
+-knappen for at tilføje kanaler:
- Påkrævet: Ambient occlusion.
- Valgfrit: Emissive. Tilføj denne kanal, hvis modellen har komponenter, der udsender lys.
- Valgfrit: Opacity. Tilføj denne kanal, hvis modellen har komponenter, der vil være gennemsigtige.
- Klik på Bake Mesh Maps i panelet Texture set settings.
- Mal teksturer på modellen.
Flere tekstursæt
Når du importerer OBJ-filen til Substance Painter, bør der kun være ét tekstursæt:

Hvis der vises mere end ét tekstursæt, var en af følgende ting forkert, da meshet blev eksporteret fra Maya:
- Meshet blev ikke kombineret til et enkelt objekt.
- Der var tildelt mere end én tekstur til meshet.
Hvis det er tilfældet, skal du eksportere modellen fra Maya igen og sørge for, at meshet er et enkelt objekt, og at der kun er tildelt én tekstur til det.
Eksport af glTF-filen fra Substance Painter
Klik på Fil > Eksporter teksturer.
Vælg glTF PBR Metal Roughness i rullemenuen Konfiguration.
Vælg den lokation, hvor du vil gemme teksturerne.
Vælg en dokumentstørrelse for at bestemme, hvor store teksturfilerne skal være.
Klik på Eksporter.
Komprimering af teksturfiler
Når du har eksporteret modellen, bør du have følgende filer:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Når du bruger konfigurationen glTF PBR Metal Roughness, eksporterer Substance Painter kun teksturfiler i PNG-format. Overvej at komprimere teksturfilerne og konvertere de teksturer, der ikke behøver en alfakanal, til en JPG. Dette reducerer den samlede filstørrelse, og mindre filstørrelser giver hurtigere downloadhastigheder og mere problemfri interaktioner.
Det er bedst at holde filstørrelsen på 4 MB eller mindre.
Opret en GLB-fil
- Besøg https://glb-packer-old.glitch.me/.
- Træk og slip de filer, du eksporterede fra Substance Painter, over på websiden GLB Packer.
En fil ved navn out.glb downloades til din computer. Når downloadet er fuldført, kan du omdøbe filen og derefter uploade den til Shopify.