Създаване на GLB файлове с помощта на Blender и Substance Painter

От версия 2.8 насам Blender може да експортира GLB файлове, които могат да бъдат добавени към продукт в администраторския панел на Shopify. За да научите повече, посетете ръководството на Blender.

За по-стари версии на Blender можете да комбинирате Blender и Substance Painter, за да експортирате GLB файл.

Подготовка на модела Ви за експортиране в Blender

За да подготвите Вашия модел за експортиране, трябва да се уверите, че той е една-единствена мрежа и че към него е приложена една-единствена текстура.

Стъпки:

  1. Натиснете „File“ > „Import“ и след това изберете правилния файлов формат за Вашия модел.
  2. Изберете файла на Вашия модел и след това натиснете „Import“.
  3. Докато държите натиснат SHIFT, щракнете с десния бутон на мишката върху всеки обект във Вашата сцена и след това натиснете Ctrl + J, за да ги обедините в една мрежа.
  4. Разгънете модела в UV пространство 0-1. Уверете се, че няма припокриващи се UV координати:
    В редактора на UV/изображения се уверете, че всички UV координати са разположени в мрежата.
  5. В редактора Properties натиснете иконата за материали.
  6. Натиснете бутона + , за да добавите нов слот за материал:
    Бутонът за добавяне на слот за материал е близо до горната част на панела „Материал“.
  7. Натиснете „Нов“.

Експортиране на мрежата от Blender

  1. Натиснете „Файл“ > „Експортиране“ > FBX (.fbx).
  2. Въведете пътя, където искате да експортирате файла.
  3. Уверете се, че използвате следните настройки за експортиране:
    Версия: FBX 7.4 двоичен. Мащаб: 1,0. Прилагане на мащабирания: Всички локални. Напред: -Z напред. Нагоре: Y нагоре. Режим на пътя: Автоматичен. Партиден режим: Изключен.
  4. Натиснете „Експортиране на FBX“.

Импортиране и подготовка на FBX файла в Substance Painter

  1. Създайте нов проект в Substance Painter, като натиснете „Файл“ > „Нов“.
  2. В диалоговия прозорец „Нов проект“ натиснете „Избор“, за да изберете мрежа.
  3. Изберете FBX файла, който сте експортирали от Blender, и след това натиснете „Отваряне“.
  4. В прозореца „Нов проект“ натиснете „OK“.
  5. Проверете дали сте експортирали правилно своята мрежа, като се уверите, че има само един набор от текстури в панела „Списък с набори от текстури“ .
  6. В панела „Настройки на набора от текстури“ натиснете бутона + , за да добавите канали:
    Бутонът + е до заглавието „Канали“. Бутонът отваря падащо меню, което показва наличните допълнителни канали.
    • Задължително: Ambient occlusion.
    • По избор: Emissive. Добавете този канал, ако моделът Ви има компоненти, които ще излъчват светлина.
    • По избор: Opacity. Добавете този канал, ако моделът Ви има компоненти, които ще бъдат прозрачни.
  7. В панела „Настройки на набора от текстури“ натиснете „Bake Mesh Maps“.
  8. Нарисувайте текстури върху модела.

Множество набори от текстури

Когато импортирате FBX файла в Substance Painter, трябва да има само един набор от текстури:

Наборите от текстури са изброени в панела „Списък с набори от текстури“.

Ако се показва повече от един набор от текстури, тогава едно от следните неща е било грешно, когато мрежата е експортирана от Blender:

  • Мрежата не е била обединена в един обект.
  • Към мрежата е била присвоена повече от една текстура.

Ако случаят е такъв, експортирайте отново модела си от Blender и се уверете, че мрежата е един обект и към нея е присвоена само една текстура.

Експортиране на glTF файла от Substance Painter

  1. Натиснете „Файл“ > „Експортиране на текстури“.

  2. От падащото меню „Config“ изберете glTF PBR Metal Roughness.

  3. Изберете местоположението, където искате да запазите своите текстури.

  4. Изберете размер на документа, за да определите колко големи ще бъдат файловете с текстури.

  5. Натиснете „Експортиране“.

Компресиране на файлове с текстури

Когато сте експортирали модела, трябва да имате следните файлове:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

Когато се използва конфигурацията glTF PBR Metal Roughness, Substance Painter експортира файлове с текстури само в PNG формат. Обмислете компресиране на файловете с текстури и конвертиране на всички текстури, които не се нуждаят от алфа канал, в JPG. Това намалява общия размер на файла, а по-малките размери на файловете позволяват по-бързи скорости на изтегляне и по-плавни взаимодействия.

Най-добре е размерът на файла Ви да е 4 MB или по-малък.

Създаване на GLB файл

  1. Посетете https://glb-packer-old.glitch.me/.
  2. Плъзнете и пуснете файловете, които сте експортирали от Substance Painter, върху уеб страницата на GLB Packer.

Файл с име out.glb ще бъде изтеглен на компютъра Ви. След като изтеглянето приключи, можете да преименувате файла и след това да го качите в Shopify.