Създаване на GLB файлове с помощта на 3ds Max и Substance Painter
Можете да използвате 3ds Max и Substance Painter, за да експортирате GLB файл, който може да бъде добавен към продукт в администраторския панел на Shopify. 3D моделите могат да помогнат на клиентите да визуализират продуктите, което може да повиши увереността и да намали връщанията.
На тази страница
Подготовка на Вашия модел за експортиране в 3ds Max
За да подготвите своя модел за експортиране, трябва да се уверите, че той е единична мрежа и че към него е приложен един-единствен материал.
Стъпки:
- Кликнете върху Файл > Импортиране... > Импортиране....
- Изберете файла на своя модел и след това кликнете върху Отвори.
- В диалоговия прозорец Опции за импортиране на OBJ поставете отметка на Импортиране като единична мрежа.
- Кликнете върху Импортиране.
- Разгънете модела в пространство 0-1. Уверете се, че няма припокриващи се UV координати:

- Приложете един-единствен материал към целия модел.
Експортиране на мрежата от 3ds Max
- Кликнете върху Файл > Експортиране > Експортиране...
- Въведете име на файла и местоположението, където искате да експортирате модела.
- От падащото меню Запиши като тип изберете OBJ-Export (.OBJ).
- Кликнете върху Запиши.
- В диалоговия прозорец Опции за експортиране на OBJ оставете опциите по подразбиране както са и кликнете върху Експортиране.
Импортиране и подготовка на OBJ файла в Substance Painter
- Създайте нов проект в Substance Painter, като кликнете върху Файл > Нов.
- В диалоговия прозорец „Нов проект“ натиснете „Select“, за да изберете мрежа.
- Изберете OBJ файла, който сте експортирали от 3ds Max, и след това натиснете „Open“.
- В прозореца „Нов проект“ натиснете „OK“.
- Проверете дали сте експортирали правилно своята мрежа, като се уверите, че има само един набор от текстури в панела „Списък с набори от текстури“ .
- Ако се показва повече от един набор от текстури, вижте „Множество набори от текстури“.
- В панела „Настройки на набор от текстури“ , натиснете
бутона „+“, за да добавите канали:
- Задължително: Околна оклузия.
- По избор: Емисионен. Добавете този канал, ако моделът Ви има компоненти, които ще излъчват светлина.
- По избор: Непрозрачност. Добавете този канал, ако моделът Ви има компоненти, които ще бъдат прозрачни.
- В панела „Настройки на набор от текстури“ натиснете „Bake Mesh Maps“.
- Нарисувайте текстури върху модела.
Множество набори от текстури
Когато импортирате OBJ файла в Substance Painter, трябва да има само един набор от текстури:

Ако се показва повече от един набор от текстури, тогава едно от следните неща е било грешно, когато мрежата е експортирана от 3ds Max:
- Мрежата не е била обединена в един обект.
- Към мрежата е била присвоена повече от една текстура.
Ако случаят е такъв, експортирайте модела си от 3ds Max отново и се уверете, че мрежата е един-единствен обект и към нея е присвоена само една текстура.
Експортиране на glTF файла от Substance Painter
Натиснете „File“ > „Export Textures“.
От падащото меню „Config“ изберете „glTF PBR Metal Roughness“.
Изберете местоположението, където искате да запазите своите текстури.
Изберете размер на документа, за да определите колко големи ще бъдат файловете с текстури.
Натиснете „Export“.
Компресиране на файлове с текстури
След като сте експортирали модела, трябва да имате следните файлове:
- modelName.bin
- modelName.glb
- modelName.gltf
- modelNamebaseColor.png
- modelNamenormal.png
- modelName_occlusionRoughnessMetallic.png
Когато използвате конфигурацията glTF PBR Metal Roughness, Substance Painter експортира файлове с текстури само в PNG формат. Обмислете компресиране на файловете с текстури и конвертиране на всички текстури, които не се нуждаят от алфа канал, в JPG. Това намалява общия размер на файла, а по-малките размери на файловете позволяват по-бързи скорости на изтегляне и по-плавни взаимодействия.
Най-добре е размерът на файла да е 4 MB или по-малък.
Създаване на GLB файл
- Посетете https://glb-packer-old.glitch.me/.
- Плъзнете и поставете файловете, които сте експортирали от Substance Painter, на уеб страницата на GLB Packer.
Файл с име out.glb ще бъде изтеглен на компютъра Ви. След като изтеглянето приключи, можете да преименувате файла и след това да го качите в Shopify.