إنشاء ملفات GLB باستخدام Maya وSubstance Painter

يمكنك استخدام Maya وSubstance Painter لتصدير ملف GLB يمكن إضافته إلى منتج في مشرف Shopify. يمكن للنماذج ثلاثية الأبعاد أن تساعد العملاء على تصوّر المنتجات، مما قد يزيد من ثقتهم ويقلل من المرتجعات.

تجهيز نموذجك للتصدير في Maya

لتجهيز نموذجك للتصدير، يجب عليك التأكد من أنه شبكة واحدة وأنه تم تطبيق خامة واحدة عليه.

الخطوات:

  1. استورد نموذجك إلى Maya بالانتقال إلى ملف (File) > استيراد... (Import...)، واختيار ملفك ثلاثي الأبعاد، ثم النقر على استيراد (Import).
  2. انقر على شبكة (Mesh) > دمج (Combine) لدمج شبكتك في كائن واحد.
  3. قم بفرد النموذج في مساحة UV بين 0-1. تأكد من عدم تداخل أي إحداثيات UV:
    استخدم محرر UV لتخطيط إحداثيات UV بين 0 و1 على محوري X وY.
  4. طبّق خامة Phong على النموذج:
    1. ضع مؤشر الماوس فوق النموذج، وانقر بزر الماوس الأيمن مع الاستمرار، ثم حدد تعيين خامة جديدة... (Assign New Material...)
    2. من مربع الحوار، حدد Phong.

تصدير الشبكة من Maya

  1. حدد الشبكة بأكملها، ثم انقر على ملف (File) > تصدير التحديد... (Export Selection...)
  2. أدخل اسم ملف والموقع الذي يجب حفظ الملف فيه.
  3. من القائمة المنسدلة أنواع الملفات (Files of type)، حدد OBJexport.
  4. انقر على تصدير التحديد (Export Selection).

استيراد ملف OBJ وتجهيزه في Substance Painter

  1. أنشئ مشروع Substance Painter جديدًا بالنقر على ملف (File) > جديد (New).
  2. في مربع الحوار مشروع جديد (New project)، انقر على تحديد (Select) لاختيار شبكة.
  3. حدد ملف OBJ الذي قمت بتصديره من Maya، ثم انقر على فتح (Open).
  4. في نافذة مشروع جديد (New project)، انقر على موافق (OK).
  5. تأكد من تصدير شبكتك بشكل صحيح عن طريق التحقق من وجود مجموعة مواد إكساء واحدة فقط في لوحة قائمة مجموعات مواد الإكساء .
  6. في لوحة إعدادات مجموعة مواد الإكساء ، انقر على زر + لإضافة قنوات:
    الزر + موجود بجانب عنوان القنوات. يفتح الزر قائمة منسدلة تعرض القنوات الإضافية المتاحة.
    • مطلوب: الانسداد المحيطي (Ambient occlusion).
    • اختياري: الانبعاث (Emissive). أضف هذه القناة إذا كان نموذجك يحتوي على مكونات ستصدر ضوءًا.
    • اختياري: الشفافية (Opacity). أضف هذه القناة إذا كان نموذجك يحتوي على مكونات ستكون شفافة.
  7. في لوحة إعدادات مجموعة مواد الإكساء (Texture set settings)، انقر على خبز خرائط الشبكة (Bake Mesh Maps).
  8. ارسم مواد الإكساء على النموذج.

مجموعات مواد إكساء متعددة

عند استيراد ملف OBJ إلى Substance Painter، يجب أن يكون هناك مجموعة مواد إكساء واحدة فقط:

مجموعات الأنسجة مدرجة في لوحة قائمة مجموعة الأنسجة.

إذا عُرضت أكثر من مجموعة أنسجة واحدة، فهذا يعني وجود أحد الأخطاء التالية عند تصدير الشبكة من Maya:

  • لم تُدمج الشبكة في كائن واحد.
  • عُيّن أكثر من نسيج واحد للشبكة.

في هذه الحالة، صدّر نموذجك من Maya مجددًا وتأكد من أن الشبكة عبارة عن كائن واحد وأنه لم يُعيّن لها سوى نسيج واحد فقط.

تصدير ملف glTF من Substance Painter

  1. انقر على ملف (File) > تصدير الأنسجة (Export Textures).

  2. من القائمة المنسدلة Config، حدّد glTF PBR Metal Roughness.

  3. اختر الموقع الذي تريد حفظ أنسجتك فيه.

  4. اختر حجم المستند لتحديد حجم ملفات النسيج.

  5. انقر على تصدير (Export).

ضغط ملفات النسيج

عندما تنتهي من تصدير النموذج، يجب أن يكون لديك الملفات التالية:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

عند استخدام تكوين glTF PBR Metal Roughness، يُصدّر Substance Painter ملفات النسيج بتنسيق PNG فقط. ضع في اعتبارك ضغط ملفات النسيج وتحويل أي أنسجة لا تحتاج إلى قناة ألفا (alpha channel) إلى تنسيق JPG. حيث يقلل ذلك من الحجم الإجمالي للملف، وتتيح أحجام الملفات الأصغر سرعات تنزيل أسرع وتفاعلات أكثر سلاسة.

يُفضل أن تبقي حجم ملفك 4 ميغابايت أو أصغر.

إنشاء ملف GLB

  1. تفضل بزيارة الرابط https://glb-packer-old.glitch.me/.
  2. اسحب وأفلت الملفات التي صدرتها من Substance Painter في صفحة الويب الخاصة بـ GLB Packer.

سيتم تنزيل ملف يسمى out.glb إلى جهاز الكمبيوتر الخاص بك. بعد اكتمال التنزيل، يمكنك إعادة تسمية الملف ثم رفعه إلى Shopify.