إنشاء ملفات GLB باستخدام Blender وSubstance Painter

بدءًا من الإصدار 2.8، يمكن لبرنامج Blender تصدير ملفات GLB التي يمكن إضافتها إلى منتج في مسؤول Shopify. لمعرفة المزيد، تفضل بزيارة دليل Blender.

بالنسبة للإصدارات الأقدم من Blender، يمكنك الجمع بين استخدام Blender وSubstance Painter لتصدير ملف GLB.

تجهيز النموذج للتصدير في Blender

لتجهيز النموذج للتصدير، يجب التأكد من أنه عبارة عن شبكة واحدة، ومن تطبيق مادة إكساء واحدة عليه.

الخطوات:

  1. انقر على ملف > استيراد (Import)، ثم حدّد تنسيق الملف الصحيح للنموذج.
  2. حدّد ملف النموذج الخاص بك، ثم انقر على استيراد.
  3. مع الاستمرار في الضغط على مفتاح SHIFT، انقر بزر الماوس الأيمن على كل كائن في المشهد، ثم اضغط على Ctrl + J لدمجهم في شبكة واحدة.
  4. قم بفك تغليف النموذج (Unwrap) ضمن مساحة 0-1 UV. تأكد من عدم تداخل أي من إحداثيات UV:
    في محرر UV/Image، تأكد من وضع جميع UVs على الشبكة.
  5. في محرر Properties (الخصائص)، انقر على أيقونة المواد.
  6. انقر على الزر + لإضافة خانة مادة جديدة:
    زر 'إضافة خانة مادة' موجود بالقرب من الجزء العلوي للوحة 'Material' (المادة).
  7. انقر على New (جديد).

تصدير الشبكة (mesh) من Blender

  1. انقر على File > Export > FBX (.fbx).
  2. أدخل المسار الذي ترغب في تصدير الملف إليه.
  3. تأكد من استخدام إعدادات التصدير التالية:
    الإصدار: FBX 7.4 binary. المقياس: 1.0. تطبيق المقاييس: All Local. للأمام: -Z Forward. للأعلى: Y Up. وضع المسار: Auto. وضع الدفعة (Batch Mode): Off.
  4. انقر على Export FBX.

استيراد ملف FBX وتجهيزه في Substance Painter

  1. أنشئ مشروعًا جديدًا في Substance Painter بالنقر على File > New.
  2. في مربع حوار New project (مشروع جديد)، انقر على Select (تحديد) لاختيار شبكة.
  3. حدد ملف FBX الذي قمت بتصديره من Blender، ثم انقر على Open (فتح).
  4. في نافذة New project (مشروع جديد)، انقر على OK (موافق).
  5. تحقق من أنك قمت بتصدير الشبكة بشكل صحيح من خلال التأكد من وجود مجموعة نسيج (texture set) واحدة فقط في لوحة Texture set list .
  6. في لوحة Texture set settings ، انقر على الزر + لإضافة قنوات:
    يوجد الزر + بجوار عنوان 'Channels' (القنوات). يفتح الزر قائمة منسدلة تعرض القنوات الإضافية المتاحة.
    • مطلوب: Ambient occlusion (الانسداد المحيط).
    • اختياري: Emissive (الانبعاث). أضف هذه القناة إذا كان النموذج الخاص بك يحتوي على مكونات ستُصدر ضوءًا.
    • اختياري: Opacity (التعتيم). أضف هذه القناة إذا كان النموذج الخاص بك يحتوي على مكونات ستكون شفافة.
  7. في لوحة Texture set settings، انقر على Bake Mesh Maps.
  8. قم بطلاء الأنسجة (textures) على النموذج.

مجموعات نسيج متعددة

عند استيراد ملف FBX إلى Substance Painter، يجب أن تكون هناك مجموعة نسيج واحدة فقط:

يتم إدراج مجموعات النسيج في لوحة 'Texture set list'.

إذا تم عرض أكثر من مجموعة نسيج واحدة، فهذا يعني أن أحد الإجراءات التالية كان خاطئًا عند تصدير الشبكة من Blender:

  • لم يتم دمج الشبكة في كائن واحد.
  • كان للشبكة أكثر من نسيج واحد مخصص لها.

إذا كانت هذه هي الحالة، فقم بتصدير النموذج الخاص بك من Blender مرة أخرى وتأكد من أن الشبكة عبارة عن كائن واحد وأن لها نسيجًا واحدًا فقط مخصصًا لها.

تصدير ملف glTF من Substance Painter

  1. انقر على File > Export Textures.

  2. من القائمة المنسدلة Config، حدد glTF PBR Metal Roughness.

  3. اختر الموقع الذي ترغب في حفظ الأنسجة فيه.

  4. اختر حجم مستند لتحديد حجم ملفات النسيج.

  5. انقر على Export (تصدير).

ضغط ملفات النسيج

عندما تقوم بتصدير النموذج، يجب أن يكون لديك الملفات التالية:

  • modelName.bin
  • modelName.glb
  • modelName.gltf
  • modelNamebaseColor.png
  • modelNamenormal.png
  • modelName_occlusionRoughnessMetallic.png

عند استخدام تكوين glTF PBR Metal Roughness، يقوم Substance Painter بتصدير ملفات النسيج بتنسيق PNG فقط. يُنصح بضغط ملفات النسيج وتحويل أي أنسجة لا تحتاج إلى قناة ألفا (alpha channel) إلى تنسيق JPG. حيث يؤدي ذلك إلى تقليل إجمالي حجم الملف، وتسمح أحجام الملفات الأصغر بسرعات تنزيل أسرع وتفاعلات أكثر سلاسة.

من الأفضل الاحتفاظ بحجم الملف الخاص بك عند 4 MB أو أصغر.

إنشاء ملف GLB

  1. تفضل بزيارة https://glb-packer-old.glitch.me/.
  2. قم بسحب وإفلات الملفات التي قمت بتصديرها من Substance Painter في صفحة الويب الخاصة بـ GLB Packer.

سيتم تنزيل ملف يسمى out.glb إلى جهاز الكمبيوتر الخاص بك. بعد اكتمال التنزيل، يمكنك إعادة تسمية الملف ثم تحميله إلى Shopify.